Shorting USB-A expansion card causes suspend errors until shutdown (allegedly)

Hello. So I just wanted to share something that has happened to me twice. Its not a big deal, but maybe something helpful for future design or even somebody as goofy as me. I dont know if that would happen to any USB-Port or with any notebook. As I have obviously found a solution, it also does not matter very much to me.

I (allegedly) shorted a microUSB cable, attached to a USB-A expansion card which led to both USB-Ports (with either of my for expansion cards) not working on that side (in this case left). This has happened to me before (on the right side), and was displaying the same following symptoms and was resolved by the same solution.

  • even though I used one of the ports, both wernt able to detect a USB-C/A stick or my logitech adapter with either expansion card (I have 4)
  • the expansion card used while shorting was working alright on the other side of the notebook
  • the power delivery and attached display (display-dockingstation combo) worked flawlessly all the time, on both ports in question. Even the one the shorting happend with.
  • debian wasnt able to suspend or hibernate, (incomplete) dmesg:
PM: dpm_run_callback(): usb_dev_suspendreturns -16
usb3: PM: failed to suspend async: error -16
PM: Some devices failed to suspend, or early wake event detected

The solution (as I have read in other topics regarding issues with the expansion cards or usb-ports) was simply to shutdown the framework for a couple of minutes.
What I dont know is, if it is irrelevant whether the power supply is detached as well or not. I tried simply shutting the machine down (with power supply attached) and restarting right after a few seconds before and it did not work.

More Details:
I am running an 11th gen i5 Framework 13, currently with debian bookworm (kernel 6.1.0).
Hoewever I have 2 USB-A, and 2 USB-C expansion cards in use, one of the latter is used to connect to a Display-Dockingstation combo.
I tried to measure some signals on a board powered by an ESP which itself was powered by the microUSB cable.
I can only assume that the shorting of GND with 3/5V (which happends now and than as some pins are directly next to each other, but it does not harm the ESP) has produced this problem.

Just to make sure, this is not an issue I need help with (even though somebody with a more detailed explanation what might have happend is appreciated), I rather wanted to share this for others.