Sleep does not sleep with power attached - Windows 10

I’m running Windows 10 on my framework laptop. I don’t have any issues with sleep in battery mode at the moment. The laptop goes to sleep mode as expected (power button slowly blinks).

But with the power adapter attached it is just not working. I press the power button and it seems like only the display is turned off and windows is locked. Also the fan turns on and ramps up to 80% within 30 seconds. The same happens when i close the lid. I can also wake the laptop by typing on my external keyboard, on which i explicitly deactivated waking up from sleep in the device manager.

Does anyone have similar problems or a solution for that?

I’m not complaining about battery drain or “modern standby” here. For me “sleep” just seems to have completely different behaviour with or without power adapter.

Do you have the power settings such that when the power is on and you press the button it will sleep ??


Yes i have…

Yes :slight_smile: I was about to post an image >

Maybe you can find something by using the powercfg application which gives better control and readouts of what is going on.

I searched again and powercfg -devicequery wake_armed shows every device that is able to wake the laptop from sleep. There were some devices (network adapter but also Thunderbolt stuff) and i deactivated waking up for every single device through the device manager. After a reboot it seems to be solved.
I hope deactivating wake up from sleep for every device does not have any negative sideffects.

1 Like

Update: No it was still not the solution. powercfg -devicequery wake_armed says NONE but still most times my laptop won’t go to sleep.

Hi Did you update the Win 10 updates form here

As far as I see my laptop shipped with 3.07 Bios.


I was thinking more on the Win10/11 driver bundle :slight_smile:

Is it possible it’s the lid sensor? Does manually setting it to sleep work?

Thanks you very much for your advice!

I am pretty sure I already installed it before, but I did it again and the problem is still happening.

Not even selecting “sleep” in the windows menu works.

The weirdest thing with the problem is that the fan goes from idle too full speed in the not working sleep mode.

1 Like

I am experiencing the same problem on Windows 11, 3.07 BIOS and updated Intel drivers. The device won’t sleep with the AC adaptor connected, but is able to while on battery. However, connecting the AC adaptor also wakes the device. Hoping to find a solution for this, too.

Edit: @Lukas I seem to have been able to make it work by disabling Fast Startup. Start → Control Panel → System and Security → Power Options → Choose What the Power Button Does → click “Change settings that are currently unavailable” and disable Fast Startup. Then restart your computer. This toggle doesn’t seem to apply unless a restart is done. Hopefully this works for you.

1 Like

Maybe it’s because he had not performed a actual restart (rather than shutting down and booting up)?

What fast startup do is, when shutting down, it saves the system kernel to harddrive when it shuts down (so it never actually reloads the kernel). However a restart will not save the kernel and thus reload it. The reason it’s called “fast startup” is because loading kernel drivers can be slow (especially on HDDs), and skipping that allows the system to startup faster.

This is also why by default Hibernation is turned off because “fast startup” is technically already a type of hibernation, except only for kernel.

I’m curious to see how the device will perform without any Framework-specific drivers. In theory there is nothing (about this laptop, at least driver-wise), that is framework-specific.

I already disabled fast startup a while ago because I was satisfied with the startup time and wanted to get a longer SSD lifetime. Did you check multiple times that it works? I realized yesterday that the sleep mode sometimes works for me, especially when I just booted. But like 10% of all tries seem to work.

Just to confirm I have [Fast startup] disabled, always been a first as otherwise there can be no fresh start. I remember there were Microsoft instructions to do a [Restart] from the power menu to clear the [Fast startup]

As this was the first thing I did on laptop arrival I’ve never had an issue with what happens when I close the lid, hibernate when on battery, sleep when on power.

Another short update: I now set the timeout for sleep in the energy settings to 5 minutes, waited a few times for that and after 5 Minutes the laptop went into sleep normally three times in a row…

It’s really weird…

How did you access the ‘energy’ settings ?

Thanks for the info, appreciated. I suspect this is probably a driver problem as well. I doubt it’s Framework-specific as this problem has been documented in the Microsoft forums as far back as 2015. Template replies as usual with no proper resolution.

Hmm… Now that I did more testing, the behavior is at best inconsistent for me as well despite Fast Startup turned off. Strange.

This is kind of a shot in the dark, but when I had Windows 10 on my machine, it did this as well. I found that switching from S0 standby connected to S0 standby disconnected did the trick. Basically modern standby is pure garbage.


I meant these settings:

You get directly to that page when you type “energy” into the windows search bar.

Thank you for your recommandation, I’m going to check that today. If that also does not work I will try upgrading to Windows 11.