[Solved] Laptop intermittently not going to sleep

Hi everyone,

When I press the power button of my laptop while booted into Windows 10 from my WD_Black SN750 2TB, the display will turn off, but more often than not the power button will remain a solid light and keep any USB peripherals on, leaving the laptop unable to enter sleep. This can happen both with and without my eGPU or any USB peripherals or expansion cards connected. In addition, I am unable to put the laptop in sleep or standby via commands (with hibernate on, rundll32 powrprof.dll,SetSuspendState with Sleep, Standby, S0, or 0,1,0 as the argument will just hibernate, and if it is off, these commands do nothing). I am able to replicate this after a reboot with no startup programs. SleepStudy does not recognize this state as a powered off state.

Supported states from powercfg with hibernate on are Standby (S0 Low Power Idle), Hibernate. The only change with hibernate off is that it is removed from the supported states.

Any suggestions? Thanks!

EDIT: Found the solution, the network driver was causing the issue (wake on magic packet and wake on pattern match). Disabling this in ‘Advanced’ under the driver settings for the AX210 and the Realtek controller allows my PC to sleep. Link to source. It wasn’t just my ethernet adapter causing this, but my network card as well, which explains why it happened sometimes while unplugged from my ethernet adapter.

EDIT 2: Problem reoccurred, was solved by stopping and disabling the Update Orchestrator Service in Services. Potentially has something to do with the fact I registry disabled Windows Update, so it’s trying to infinitely access the Windows Update service which is not running. It seems a lot of different things may cause the issue, will update periodically if I encounter more.

From an elevated command prompt can you type the following and share the results:
powrcfg -lastwake

This tells you what woke the system. Now if your system is never able to hit suspend this wont be very useful.

However there are applications which can prevent sleep, such as backup software, anti-virus software, and even some windows updates.

Most likely something you’ve installed is inhibiting standby in this case.

-lastwake might shed some light on the matter.

Also for your information S0 puts the computer into a low power state, similar to standby. Once 5% of the battery has been used the system automatically enters hibernation. So whether you have hibernation enabled or not, really only changes whether you can directly activate hibernation instead of being able to hit it only after suspend has used 5% battery.

1 Like

It displays zero entries, sadly. I found a solution, see my edit for clarification. Thanks anyway!