Slow time to POST and wake-up from S3

With my 11th gen laptop, when cold booting or waking up from S3 standby (ie. ‘deep sleep’), there’s a pause of at least 6 seconds, but sometimes as high as 10. For comparison, my 2017 Lenovo Yoga takes anywhere from 0.5-1.5 seconds.

This is before anything even appears on the screen. The screen usually becomes backlit a second or two before an output appears. In the case of S3 wake-up, caps lock doesn’t become usable until the screen lights up, so I think it’s likely this is a hardware or BIOS issue.

I’ve seen several similar issues talked about here - eg. the laptop taking a much longer time to POST or boot (eg. 60 seconds) but not for this (shorter but still annoying) amount of time. I’ve tried toggling quick boot, text mode boot, USB boot, etc. and have tried with and without my expansion cards inserted.

Has anyone had anything similar? Any ideas on how I’d fix this?

Edit: note that this is with BIOS 3.10. Same applied before I updated it though

1 Like

The POST from cold bootup is also slow on my 11th gen unit. (Similar to you in the 6-10 range)

1 Like

@snoopdouglas The official response around S3 is that it is not supported officially by Intel on Tigerlake-U. Generally it kind of works, but the power savings over S0ix is minimal.
I can confirm the wake time is long when resuming from S3. But we have not profiled why.


Any word regarding the 6-10 seconds POST time?

(Time between power button being pressed, and loading the Windows boot manager or grub)

@Second_Coming do you have a lot of peripherals connected? USB enumeration adds additional time to POST.

@Kieran_Levin, only 4 USB-C expansion cards, with no peripherals plugged into them.

POSTing still takes a long time for me regardless of the expansion cards inserted.

I should also note that S3 - despite apparently not being supported - gives me power savings over s2idle. So I’ve got a laptop that’s slow to boot, and a choice between it being slow to wake or losing power at an unacceptably high rate while asleep.

Framework support are currently arguing that this is expected behaviour. @Kieran_Levin can you tell me how long your Framework laptop takes to get from pressing the power button to seeing the logo on screen?

…they’re not wrong…in the sense that it’s expected behaviour given the lack of polish / optimization…sadly.

I guess I’ll try another question: does anyone’s Framework laptop take less than 5 seconds to POST?

The middle ground that I use is s2idle sleep, but then hibernate after 1 hour on battery. It means I have more than enough juice pulling it out from a backpack without having to cold boot often.

My POST time (time to logo) is 10-11 seconds (on battery, nothing plugged in)

Interesting - are you using an 11th or 12th gen mainboard?

Mine takes a long time to post as well

1 Like