SN850 firmware update

So I have a small problem updating the firmware of the WD SN850 SSD.
I run the i5 model with Ubuntu 21.10 and had the typical problems with random SSD-disconnects.
Sadly the WD Dashboard is only available on Windows so I picked the NVME out of the framework into an USB-C adapter.
The WD Dashboard could see a drive but without any specific model information.
So I did what I wanted to avoid and installed Win10 on the framework.
Now the dashboard let me update the SN850 firmware to 613…wd but not the required 614900wd.
And now is says that the firmware is up-to-date and windows update has nothing either.

Any ideas what I can do now ?
The instability problems still persist.

1 Like

Go to intel.com and run the automatic updates utility.

When I built my machine with a SN850 I put on the Framework driver pack and then went to Intel to check for any other drivers. IIRC there were three more that went on from Intel. I cant remember what they were.

I then updated the firmware on the SN850 and its been fine. I have to say I didn’t really have any issues before that.

Note that 613xxx and 614xxx are different firmware series from Western Digital covering slightly different hardware revisions, so if you have the latest 613xxx, you are all set.

2 Likes

Thank you. WD is a bit short about firmware information.
But on the fresh Win10 install with framework driver pack, wd Dashboard up-to-date and Intel drivers updated and Windows Update running I still have the sudden SSD disconnects.
On top I checked if the SSD is seated correctly.
I emailed support again, so let’s see what I can try next.

Just out of curiosity, are you noticing any disconnects while running Windows?

Yes, it bluescreens frequently and while rebooting it often can’t detect the boot drive on the first try.

At this stage swap in a borrowed or hanging around 120/250GB NVMe and see if it works with that. Then if it does, RMA time.

1 Like

I wanted to add that I’m having the same issue with my laptop, running Ubuntu 22.04. I’ve booted Windows on a USB stick and ran the Intel Update Utility. I’m on the latest 3.07 BIOS and am on version 614900WD. I’ve been getting random disconnects on Ubuntu.

I can’t get the Western Digital Utility to run, but it looks like I’m on the latest version. I used to run Windows but switched recently. Anyone have any luck figuring this one out?

There are issues with the WD disk even on the latest firmware. I’d recommend everyone with a WD SN850 to replace it with one from another manufacturer. Make sure to contact Framework support about it.

Issue was discussed here:

Mines working fine, in fact best NVMe drive I’ve had. :grinning:

But I am using Windows 11 so…

1 Like

@Jason_Dagless Yeah, I might should’ve added that it only has issues with Linux. I did put mine into my Windows desktop and it does work there aswell.

Strange, I have had no issues on my WD SN850 so far. I am running Slackware Linux on it currently, ran it with Windows 11 also for a day or so.

2 Likes

@5uie1 It’s very likely that not all units of the disk have the issue. Manufacturers exchange parts and different revisions of the same product might not behave exactly the same.
For mine, it was not necessarily apparent and quite irregular. Sometimes the machine could run for a day or more without freezing or other issues. I guess it heavily depends on the workload. You should definitely check kernel logs for NVME related errors and warnings if you haven’t already. Might as well run a load while doing it. Your drive might be good though but people who get strange behavior with the SN850 on linux might want to try replacing it with a different model. At least that’s what worked for me and a few others in the thread I linked previously.

Mine’s also working fine on Linux Mint. I have another on my desktop too, also working fine.

2 Likes

To add another data point to the discussion:

My SN850 (1 TB) is working with out any issues (Win 10, PopOS 22.04).

According to the intel utility I´m on firmware version 611100WD, no firmware update is recommended to me.

2 Likes

Yeah also no issues with the 850, running fedora 35 for several months and since a few weeks 36. had not a single problem with the SSD so far.
But I bought it separately at German Amazon, not from Framework. Maybe this makes a difference?

1 Like

Howdy folks. So, I swapped my SSD out, was using an WD SN850 sourced via NewEgg, date of manufacture was January 7, 2022. Turns out the SSD/nvme was slightly bowed out, causing a disconnect with heavy typing or use in lap!

I have used a 1mm NVMe thermal pad on mine since I got it. It slightly bonds the keyboard to the drive when you lift the lid so I know its making full contact. Might sort out any bowing issues, especially if upward.

Unfortunately, a new SSD did not fix the issue. Same issues are occurring.

Some additional context:

  • Fedora 36
  • Seems to be worse/happen when I run Teams or Slack
  • Related issue is that it seems to go to idle even when all power management is set to not suspect/idle. I haven’t supplied the sleep state of deep yet on this fresh install.

For future reference, if a newer firmware version is released and you want to update without installing Windows again, check out this guide:

3 Likes