[SOLVED] 11Gen i5 Laptop won't turn on :(


There’s a known issue with 11th Gen that’s like this. I also experienced it once, after allowing my laptop to remain discharged for a couple weeks. Fully Resetting the Motherboard State fixed mine, same as yours.

This statement from Nirav Patel explains exactly what’s going on: Viability of an ML 1220 rechargable battery for RTC | CMOS (11th gen) - #43 by nrp

You might be seeing this issue.


Machine came up. Thank you Jesus!!


So then the system only charges the battery from mains? Therefore if its left unplugged for a long time or if its only left plugged in to charge, the RTC battery can discharge and cause the battery to enter this state?

Yeah. Again, normally this would just result in a system clock reset, but unfortunately there’s a bug in the 11th gen CPU that will sometimes give this result.

Is there a register that can be read in windows that I can use to alert me of the pending doom? Or should I remove the battery and live without it. I will be in a very difficult situation if I’m at a trade show and suddenly the machine won’t power on.


I’ve hadn’t thought of taking out the RTC battery completely … that could work, but if you don’t constantly have an internet connection, you’ll be resetting the system time yourself.

You can also leave a power bank plugged into the laptop. That way, you can keep both of the laptop’s batteries fully charged while traveling. Could solve the issue depending on how often you can plug in. Having a power bank tends to be a good idea anyway given the poor battery life of the Framework.


I use this power bank, but there might be better ones now. Haven’t shopped for them in a while.

1 Like

I have a power bank, but I won’t like to wear out its life just for this. I guess I’ll leave the laptop plugged in for a while at the desk. Well, I have an iPad to keep me company at my bedside.

Seems I’ll need to upgrade to the 12th Gen in the near future.

1 Like

@Jacob_Padgett wait a sec. Doesn’t this then mean that all 11gen laptops would have this problem? How are other companies allowing users to reset their devices?

I mean, it’s just as easy to remove the RTC battery on any other brand of windows laptop. I’m not sure if any other manufacturers have come out with official statements, but I assume their various support channels are aware. They may also have built-in mitigations that make the issue less common, such as allowing the RTC battery to charge directly from the primary battery (as Framework did with 12th Gen) (regardless of this CPU bug, you normally don’t want the RTC battery to die anyway). Framework was new to the game, after all. But that’s all just speculation, I don’t really know.

The problem has many facets.

Most laptops don’t use rechargeable CMOS batteries that go kaput after ~10 deep discharges. And might not require a CMOS battery to be able to boot. For 12th gen it can trickle-charge from main battery, and they’ve offered expert-level directions for modding the 11th gen board to do the same.

Jacob mentions the ability of others to maybe charge directly from the primary battery, but there’s also the point that they might not use chargeable batteries at all - why drain CMOS if there’s power available elsewhere from a comparatively MASSIVE battery?

Basically, my estimation: FW tried to do the good thing by going rechargeable, and didn’t spot a possibly disastrous edge case (“what if the chipset… … …”), and this unlikely edge case turned out to happen. Extremely annoying, shitty luck, and I hated the months of back-and-forth this cost me in support. But credit where credit is due, they did get me back to a functioning machine.

So if you have this issue, talk to support. They’ll probably ask you to try a few things and either issue you a new motherboard (if the socket is suspected faulty), or issue you a new battery.


It’s because no it’s not an issue with the CPU, but with how the mainboard was designed (it was fixed for the 12th-gen Framework).

There even are rework instructions for the 11th-gen available for the bravests of us (it’s not for everyone, it requires experience in electronics manual work):


Alright, so it is the board. And no my solder skills are not up to par; I will not be making that mod. When I religate this 11th Gen board to a NAS, I will no longer have that problem because it will always be plugged in.

@Shawn_Lewis It might still be worth contacting FW to see about a replacement board or battery. Why live with the problem if you don’t have to? Especially for critical business functions…

1 Like

@GhostLegion If I am not mistaken, a replacement board will still have the same problem. The solution is just to make sure to use the laptop every now and then, e.g. at least once a week, so that the RTC battery will not end up empty.

1 Like

That depends on what the problem is. If the RTC battery has been deep-cycled too many times to hold a charge, then FW will issue a replacement battery. If the issue is the battery holder not making contact with the battery, FW will issue a new board.

1 Like

Buying the 2 dollar battery myself might be faster though. It is pretty common?

@Shawn_Lewis It needs to be rechargeable tho, just make sure of that.

This thread has saved my framework laptop from being discarded. This has been happening to me if I let the laptop sit unplugged for more than a day. It isn’t even a chance, it just happens to my laptop a lot. It does reset itself eventually, but I had almost given up on my machine because of this. Thank you for the thread and help!

1 Like

If it’s happening over just a day of downtime, contact support! This should take weeks, but if your battery has been deep-cycled too many times, it will no longer hold a charge. If you charged your laptop for 24 hours (so the battery can trickle-charge all the way) and you’re still having this issue persistently, contact support so they can send you a replacement RTC battery. They will do so even if the laptop is out of warranty.


Thanks @Morpheus636, I will contact them, Thank you!