[solved] 4 weeks no feedback from the support team! - Please reply

4 weeks no feedback from the support team! - Please reply


  • Emails sent to support@frame.work.
  • Neither “Email could not be delivered” nor replies in my SPAM mailbox.
  • No answer for 4 weeks

Framework 16 with GPU-Module

Hardware errors:

  • Battery is not recognized as connected; only with original-USB power supply operation possible
  • Trackpad hard click gets stuck

Software errors:

  • Fedora 39 is never booted automatically (have to press “Boot Option Key” every time to Boot OS)
  • Complete shutdown is not possible

(sent this following text also via Email to: support@frame.work)

Hi Framework Support Team!

Unfortunately, I have not yet received any feedback or a solution to the problems I reported. This has not only caused considerable inconvenience in my daily work life, but also affects my trust in your customer service.

As I am very interested in a quick and satisfactory solution, I would like to ask you to prioritize the matter and offer me either a rectification, a replacement or a full refund of the purchase price. I hope for your understanding and cooperation so that we can resolve this matter together as quickly as possible.

Please let me know by May 9 at the latest what steps you will take to rectify the situation. I am confident that we can find a solution that is satisfactory to both sides.

Thank you for your attention and assistance in resolving this issue. I look forward to hearing back from you soon.


Previous email history for details:

Gesendet: Samstag, 20. April 2024 um 15:03 Uhr
Von: -
An: support@frame.work
Betreff: Fw: Re: Submission from Service Request Form: Battery Issue - Laptop Failure to Start

Need your help:

The following additional problems have occurred to the existing battery problem described below:


Gesendet: Mittwoch, 17. April 2024 um 18:15 Uhr
Von: -
An: support@frame.work
Betreff: Fw: Re: Submission from Service Request Form: Battery Issue - Laptop Failure to Start

The battery is not recognized by the laptop, no matter how I position it in the housing.
I have updated the BIOS (to 3.03) because of the following point:

  • Fix battery cutoff behavior.

Unfortunately, this has not been successful.
See video:

Please help!


Gesendet: Montag, 08. April 2024 um 08:53 Uhr
Von: -
An: support@frame.work
Betreff: Fw: Re: Submission from Service Request Form: Battery Issue - Laptop Failure to Start
Did you receive my previous email?
I haven’t received any feedback yet as to whether you have received the email or whether you are already working on the problem.


Gesendet: Freitag, 29. März 2024 um 01:23 Uhr
Von: -
An: support@frame.work
Betreff: Re: Submission from Service Request Form: Battery Issue - Laptop Failure to Start
Thanks for the feedback, find the answers to your questions below.


On Wed, 2024-03-27 at 22:42 +0000, Riley wrote:
Framework Support

Thank you for contacting Framework Support. We're sorry to hear that you are having a problem with your Framework Laptop battery. We are here to assist you.

Before we dive in, can we have the following information:

1. When did you start noticing the problem?
Right from the start.
Even when starting the laptop for the first time.

2. Is it consistent or does it happen on and off?
The problem occurs at least once per battery charge.
This means when the battery has been charged to at least 90% and is then used afterwards.

3. What solutions have you already tried on your own aside from what is previously mentioned?
No other solution from my side except those mentioned at the beginning.

4. Can you send us a photo/video demonstrating the issue?
Yes, see point 8 below for the video.

5. What is your current Operating system installed prior to the issue?

Windows 11 then Fedora 39 and then Clear Linux.
(Problem is there for all 3 OS)

6. Did you make any hardware/software modifications prior to the issue?
No, I just took the laptop out of the box and installed RAM, SSD, battery + remaining DIY framework components (keyboard etc.).

7. Did you use any dock/hub, third-party charger, or an eGPU enclosure to charge the laptop?
None of that.
Only the original power supply unit and cables that were supplied.

8. Could you send a video demonstration of the complete side LED codes? Those are diagnostic codes that could help us to isolate the issue better. You can upload it to YouTube or Google Drive, then send the link here. Please record at least 2 minutes. The diagnostic codes usually appear after a minute.
Video can be downloaded here (~35 MB):
(removed link)
Video description:
Laptop in battery mode during web browsing.
Shows a "battery not installed" symbol in the taskbar at about 89% battery charge.
Screen goes black.
Power button/fingerprint remains active.
No LED display active on the side.
Short press/long press of the power button does nothing => no reset possible.
Battery must be removed to restart the laptop.

The answers to these questions will help me dig deeper and find a more personalized solution to your problem.

We're looking forward to your response.
Framework Support
    On Wed, Mar 27, 2024 at 12:01 PM <support@frame.work> wrote:


        Thanks for reaching out. Unless you clicked “Yes, close my request” on one of our suggested articles, a member of the Framework Support team will be with you as soon as possible. Responses outside of weekdays and working hours in the US may be delayed. If there are any photos, videos, or screenshots that would help us resolve the issue, please reply with them attached.

        Framework Support is currently under extreme contact volume due to the start of batch processing for Framework Laptop 16. Responses will be delayed. We are working as quickly as possible to respond to inquiries in the order they were received. Thank you for your patience.

        In the meantime, check out the Knowledge Base​, Framework Community​, and our step-by-step guides​ for information.
        On Wed, Mar 27, 2024 at 12:00 PM <Email> wrote:

            Supportfrage-Kategorie: problem-with-my-framework-laptop

            E-Mail: -

            Thema: Battery Issue - Laptop Failure to Start

            Beschreibung: I am experiencing a persistent issue with my laptop's battery, leading to startup failure and black screen occurrences.

            - The battery indicator on the taskbar switches sometime from charging to indicating no battery present.
            (If on battery only a black screen occurs then, leaving the laptop unstartable.)
            - Workaround requires disassembly, battery removal, reinsertion, and plugging in the power cable.
            - The issue occurs randomly at various battery levels, including around 70%, 30%, and just below 10%, indicating inconsistency in its occurrence across different charge states.
            - The laptop operates flawlessly on AC power without the battery.
            - The battery shows no visible damage or bent pins.
            - Minor adjustments in battery positioning during reassembly do not resolve the issue.

            I kindly request assistance in troubleshooting and resolving this battery-related startup issue. Thank you for your Help.

Need additional help?  Check out the Framework Support pages.

© 2021 Framework Computer Inc
447 Sutter St, PMB 135, San Francisco, CA, 94108-4618

They’re very busy right now, but that seems very unusual, from what I’ve heard.

I’m sure someone from Framework will see your message and look into it, though it might take a bit as I don’t know how fanatical they are about checking the forums on weekends.

@Destroya Something for You, I think :slight_smile:


Hey there, thank you for reporting this issue to us. when I check your support case, the last response I see is from the support team (it is the email you have shared here) but I don’t see your responses to that. Looks like we did not receive your emails on march 29, April 8, April 17 or April 20. That is very odd.

Did you reply back using the original email address?

Can you please check if you have any issues with your email service provider?

It is very strange that we have not received any email from you, this is not an issue I’ve seen before.


All emails have been sent to
from the email address I used to register at Framework.
(I have not received any error messages about incorrect deliveries.)

The 29 March email was sent in the format:
“First name L.” myemail.address@registeredatFramework.

8 April and others in the format:

I sent a message to an @hotmail address yesterday, and received feedback from the user that it was delivered.
So I can exclude problems with my email provider.

Could you please embed the email history in the ticket as the issues still match the description. So that the support team can finally start their work.

This is not matching what I see on my end actually, can you please try to reply back to the original email thread with the original email address that you have registered with us? I can confirm if we receive that email or not.

I sent the first forum entry again in response to the following e-mail message some minutes ago.

Sent: Thursday, 28 March 2024 00:42
From: “Riley” support@frame.work
To: Sent you the email adress via PM
Subject: Re: Transmission from Service Request Form: Battery problem - laptop will no longer start

I received an answer from the support team yesterday 2024-04-30 and answered it today (a few minutes ago).
Wonder if the email will reach Framework this time.

Looks like we replied to you about an hour ago, please let me know if you have not received the email.

1 Like

I have received a reply from them.
Communication with me and the support team now seems to be working.

Thank you very much for your help!
In my opinion, the topic can be closed.

1 Like