[SOLVED] BIOS upgrade stuck

This is a post to keep a record of an issue I had and how I resolved it, maybe this will help someone.

I have received a DIY Edition of Framework Laptop 13, 11th Gen Intel yesterday. I followed the guide to assemble it and the other guide to install the latest Ubuntu 23.04. It prompted to upgrade BIOS because my BIOS version was 3.07.

The laptop was already connected to power. I ran fwupdmgr enable-remote lvfs-testing, modified uefi_capsule.conf, and ran fwupdmgr update. It asked which version of BIOS I wanted to upgrade to, and I chose the latest 3.17.

The laptop rebooted, and displayed a screen with the Framework logo and the text “fwupd-efi version 1.14”. The fan started whirring. After 10 minutes of watching this screen, I started looking online for how long the BIOS update of a Framework laptop should take and found no information. 30 minutes after start, I tried to reach out to support. 60 minutes after the start, I decided that even support was unlikely to recommend me anything other than turning it off. I pressed the power button and held for 10 seconds to turn the laptop off. After turning it back on, it booted into the normal BIOS upgrade mode and proceeded to successfully upgrade it. This took like 4-5 minutes. Afterwards, I could boot the laptop into Ubuntu normally.


Hi @Tom_Adler welcome to Framework community and thanks for sharing you bios upgrade guide, appreciate it.


that exact thing happened to me. thank you for giving me the confident to shut that thing down.

1 Like