[Solved - Caused by drivers] Brightness control not working on Windows 11?

Installed 12 gen 1280P. I have updated drivers, and have reinstalled the latest intel driver GFX_WIN_101.343_101.211
I have uninstalled and reinstalled and the screen still does not react to sliders on F7 F8 keys and is on blast. Thanks for your help.

Can you clarify what you meant by this? (e.g. which drivers, from where)

I used the framework bundle and then downloaded the the intel driver application and updated as per app.

Which framework bundle?

There’s one for 11th gen. And then there’s one for 12th gen.


Will doublecheck I installed the 12th gen

redownloaded the 12th gen bundle , installed, restarted, and the the DCH driver Intel program recommended. Neither of which changed the functionality of the screen dimmer. The dimmer shows up but does not change brightness. Maybe I need to open up laptop and unplug screen and reconnect?

You mentioned that you’ve installed “latest intel driver GFX_WIN_101.343_101.211”.

Can you uninstall that? Reboot, then run the 12th gen driver bundle installation again. This should install the intel driver combo that’s been tested by FW.

If that still doesn’t work, reach out to FW Support.

Well it looks like I had a driver that was meant for an LG display. When I searched the drivers and removed it, slider works again! thanks for the help.

1 Like