[SOLVED] eGPU card not seen

Hey all, hoping someone can help out. Had a browse of the forum and couldn’t find a solution.

TLDR: card isn’t being seen by the laptop.

Running a 12th gen Framework, Win11, and trying to connect an eGPU to it. I have ran the driver bundle provided by framework.

The eGPU enclosure is a Razer Core X, with a 3060 inside. (the GPU is definitely good as it is out of my desktop.)

The device is powered, the fans on the GPU and enclosure are running and RGB on the card is on too.

In device manager the Core X is seen in USB devices; however, the 3060 is not seen in the Display Adapters nor is it displayed in task manager

I am unable to download Nvidea drivers as you must have a recognised card in order to do this.

Am I missing something here?
TYIA, James

Not that it should matter much but have you tried booting with the eGPU already plugged in or vice versa?

Yes, I have tried plug and play, and from shutdown (several times, all ports, various cables). It is also charging the laptop fine.

I do also get the notification ‘Thunderbolt device functionality might be limited’ on plugging in.

What cable are you using? Thunderbolt can be picky about cables and not every USB-C cable can do Thunderbolt. If it’s the cable that came with the dock, then that’s probably fine and the problem is something else, but otherwise try grabbing a new cable that’s specifically Thunderbolt capable.

Or if you want it right now, Apple’s Thunderbolt cables are fine and widely available at Apple stores and Best Buy and such.

So, I also wasn’t convinced it wasn’t the cable either. However, I tried the TB3 cable that it came with, I also tried an apple one that we use with the Mac - to no avail.

I went to Currys and bought a USB4/TB4 cable to be absolutely sure, it now sees the card and works fine.

So, to anyone in the future that has this issue and reads this…it may just be you need a more capable cable for your GPU - don’t trust the one that the eGPU comes with. I got a Logik USB4 cable for £25.


It might be something on the laptop side. I don’t expect at all that the cable provided by razer is not working.

I am sure that is the case Cristian, and is a bit of an idiosyncrasy with this particular system. (although looking on other forums people have had similar issues and then just received replacements from Razer). This eGPU in particular was working fine from the person I got it off, and they used the supplied cable from Razer.

But this is the situation at my end…problem is solved with a new USB4 cable on the Framework 12G. So anyone in the future, if you get into bother with your enclosure, this may be a solution for you. Also, it works a treat, great performance for gaming!

1 Like

I’m thinking about getting one as well, but waiting for TB4 models and RDNA3.
If you have any additional issue, please mention them since it is helpful for others as well