Thunderbolt 3 eGPU not being shown in Device Manager (Windows 10)

Enclosure: Thunderbolt™ 3 Mini eGFX External GPU Enclosure 240W

GPU: Gigabyte GeForce RTX™ 4060 D6 8G (GV-N4060D6-8GD)

Laptop: Framework Laptop 13 (11th gen Intel), i5-1135G7 CPU, 16 GB RAM

Hey guys, I have been running into an issue that I can’t seem to find an answer to anywhere else. My eGPU enclosure is being recognized by the Thunderbolt control center, but the GPU I have connected is not being recognized by Device Manager or any of the Nvidia Drivers I attempt to install. The GPU fan spins when I have it plugged in, but it does not allow me to see it in Device Manager (yes, even when I enable hidden devices). Has anyone else had this kind of issue?

I have tried uninstalling all Graphics Drivers, updating windows, and re-installing the Framework laptop BIOS and Drivers. I have also tried both of the back two ports on the laptop, as well as plugging in AC power first, and then plugging in the eGPU after, and every variation of having the eGPU plugged in or not during startup. The same issue persists. I am currently in the process of ordering a new Thunderbolt cable, to use rather than the one that came with the original enclosure. But I doubt that the cable is the issue. So, any ideas?

This has been cross posted on eGpu io here: Link
This has also been cross-posted on Reddit, please see additional info there: Reddit Link

Update: I have swapped out the cable and used a stronger PSU, neither of these things have fixed the issue. I have tested the enclosure using a PCIe Wi-Fi card, and in that case, the Wi-Fi card was picked up immediately. So, I tested the GPU in my main system, and it also got picked up perfectly there. The error only occurs when the GPU is in the enclosure, and not with other PCIe cards. My current theory is that there is something wrong with the Enclosure’s internal power cord that connects to the GPU, since the PCIe slot seems to work fine. Any other theories are very welcome.

I have also tested the pin-out on the power cable that goes to the GPU, and there is no problem with the voltage. I am truly stumped as to how all of these parts work individually, but not together.

could you provide a screenshot from Intel Thunderbolt Control Center?


This looks better than I thought, thought you might see an indication of missing authorization

Yeah, everything looks perfectly fine except the GPU does not show in Device manager. I even put a Wi-Fi PCIe card into the enclosure, and it showed right up in Device manager. So I tested the GPU in my main system, and lo and behold, it shows up perfectly there as well! So it’s not the GPU’s fault. I also tested the power delivery to GPU, and it is great. I even tested with a more powerful PSU, and it still doesn’t show in Device Manager.

Since I’m currently stuck on another Thunderbolt problem where I suspect differences in the ports… Have you tried other Thunderbolt ports on the notebook? (For my problem I am currently downloading the ISOs of Ubuntu and Fedora)

I have used both back ports. But all of them are technically Thunderbolt, so I will try the rest as well.

Edit: None of the other ports work either.

I have found that whenever I plug in the enclosure, I get multiple “Metadata staging failed” in Event Viewer, as you can see here:

Did you ever find a solution to this? I’m trying to use a FW16 and a USB4 dock with a 2080, it appears in device manager but monitors plugged into it aren’t recognized.

I don’t know if this will help but I found the following M$ discussion thread about Event ID 131 after plugging in USB devices. Check the 3rd reply from John Trembly_019.

I’ve never experienced an Event ID 131 before but perhaps there is something unique about the chipset or eGPU that may trigger the Metadata issue.


No, I have not found a solution to this yet. It seems to have hit a wall. I tried a new install of windows with still no luck. Next is to try Linux.