eGPU through Thunderbolt 3 isn't being recognized

I’ve been working on setting up my Framework to be a scalable gaming rig. After much research, I was able to make the following build:

Everything fits correctly with the setup. I even saw other folks on are doing a similar setup. However, when I hook it up to my Framework laptop with the Thunderbolt 3 cable that came with it, only the gaming box fan runs and charges my laptop. I made sure I have the Thunderbolt Control Center installed.

From reading online, it supposed to be a simple plug-and-play setup. I tested it on my HP work laptop and it was able to run no problem. The ASUS GPU lights up to show that it’s working and I was able to install the NVIDIA driver after that.

It seems to be a Framework issue since it still wont work on this laptop. I’ve search through the forums on here and it seems other folks have had issues as well, but they never mentioned the solution.

Has anyone else has this? I’m running Windows 10 and wondering if there’s somethin in the BIOS or somewhere else I need to tweak to have the Thunderbolt connection work.


This happened to me only once when I was using an eGPU, For some reason the the eGPU would provide power to the board but didn’t turn on the GPU… and the solution was to turn the laptop battery back on in the BIOS. (I tried to set the battery not to charge because I knew I was going to be gaming for a few hours and didn’t want to damage the laptop battery). Not sure if that helps… I assume the battery is no longer connected to the laptop?

I have a “ritual” that I have to go through in order to get my Sonnett eGPU enclosure to actually work.

I have to start with the laptop completely off. Then I turn on the laptop on with the thunderbolt cable plugged in or turn on the laptop and plug in the thunderbolt cable before the Framework logo pops up.

If the laptop refuses to post, but the eGPU light is on, then I can move on. If the laptop POSTs and boots into Windows, try again. I’m not sure if the not POSTing part is something specific to my eGPU enclosure, or reproducible on other brands. However, this steps seems to register the enclosure to the onboard Thunderbolt controller.

When the laptop is refusing the POST, the screen should be still on (blank, black screen), and the little LED on the side of the laptop should be flashing. At this point, I wait for the flashing sequence to end before I hold the power button down to hard reset the laptop. Next, I turn on the laptop again. This time the laptop should POST successfully, but before the laptop goes into Windows, I unplug and replug in the thunderbolt cable.

The eGPU enclosure light should light up. As the laptop boots into Windows, the GPU should now show up in Device Manager, or the Thunderbolt Control Center should recognize the dock. If not, I try reattaching the cable. If the light still doesn’t turn on, I try the “ritual” again. In Windows, the eGPU dock should be plug-n-play at this point. I usually use Linux so the situation is slightly different, but the GPU is still functional.

Honestly, I’m not sure how helpful this is for everyone else. But it definitely shows how wonky Thunderbolt support is, and why the laptop doesn’t have official Thunderbolt Certification.

@tokanada, do you really have to do all that?.. I also use a sonnentt and unless I make the mistake of turning off the battery charging in the bios I don’t have ANY of the issues you have… it’s just plug and play for me… off or on it knows exactly what to do every time I plug in the TB cable. What GPU / OS are you using? I am using an old 1060 6GB w/ Windows 11. Only drivers I needed to install were nVidia display drivers.

Doesn’t matter whether I’m using Linux or Windows, my Framework laptop won’t recognize the eGPU unless I follow the steps above.

What do you mean by POST in this case? As-in getting the laptop to connect to the eGPU before it fully boots up?

Do I need to do some configuration in the BIOS to make sure Thunderbolt works?

When I reconnected the eGPU back to my other HP laptop, I’m also having the same issue. I found a video where someone has done the same build as me for their AORUS GPU. The only difference is this guy has a 3060 and mine is the 3060 Ti which is more powerful. You can see in one of the comments someone says:

Recommended PSU for the 3060 card was 650W according to the asus website and 750W for the 3060TI. Might be a difference here in the type of powersupply so the recommendation might not apply here.

So is the build in 450W power supply able to sufficiently drive the 3060 ? Or 3060ti for that matter ?

This gives me the impression that the original AORUS gaming box PSU is not enough (450W). Maybe getting a stronger PSU can help? I also read that I can limit the power supply of the GPU using NVIDIA Experience or MSI Afterburner. What do you folks think?

POST stands for Power On Self Test. When a computer powers on, it runs a series of checks to ensure the hardware is all good before loading any other software. If it detects an issue, it will throw an error code (POST code) through a series of beeps, flashing LED’s or similar to identify the issue and will refuse to boot the computer any farther.

This is what @tokanada means when it refuses to POST. If you have your eGPU plugged in while it’s booting and your laptop throws a POST code and doesn’t boot, there is some kind of issue on the hardware level that prevents the computer from continuing to boot. If this is the case for you, then I think it might be safe to assume you’re power supply might not be giving enough to the 3060Ti, though other hardware problems could also play a part.

1 Like

Gotcha. When I boot it up with the eGPU connected, the laptop still starts up no problem. I hear the eGPU’s internal fan running and see it charging my laptop, but the NVIDIA GPU itself doesn’t run.

With my non-Framework laptop, I did the following:

  1. Started up the laptop and logged in
  2. Wait about 5 minutes for everything to load in the background
  3. Connect the power cord to the eGPU
  4. Connect the Thunderbold cable to the laptop’s Thunderbolt port

Then everything turned on as expected. When I connect it all immediately after the laptop loaded to the home screen, the GPU would show a flash and then turn off. It seemed that letting the PC run whatever background processes for a few minutes, and then connecting, that worked. I would sometimes disconnect and reconnect until it worked.

When I tried to do the same on the Framework, no dice. I see the GPU power up the light, but it goes away. I tried all of the modular ports just to be sure. There are a few posts where people have their Framework run with their eGPU. I feel like I’m close, but missing something, perhaps a BIOS setting…

Also, according to one of the Reddit comments, the PSU should be enough to support the GPU. They said:

If you run it at the same time as your PC, maybe you are running out of power for a moment?

The 1080 (170w) and 2070 (180w) are from the same series, so the 3060 (180w) could work.

The Gaming Box is a Flex power supply, so there isn’t much variety…

It seems that the 3060 needs a minimum of 180W? That’s how I understood it.

@ethanosullivan As far as I know, there are no controls for Thunderbolt or even graphics card settings in the Framework’s BIOS

Some other questions I have, Do you have the Framework plugged into AC power when you are connecting the GPU? If not, the laptop could be attempting to draw power from the enclosure as well, which could definitely overwork that PSU if it’s trying to power the card and laptop.

Something else to look into would be your Drivers themselves. Since the topic suggests this is a DIY model, did you download and install the Framework Driver bundle for Windows from these forums? If not, it could be that Windows just downloaded their generic drivers which may or may not fully take advantage of Thunderbolt. I would try updating to the latest BIOS and installing their latest Driver bundle, which includes Intel Thunderbolt Drivers, and see if these issues persist. Make sure you get the Windows 10, and not their Alpha for Windows 11.


Yup, I updated to v3.07 when it was released. I ran the installation again just to be sure.

This is what I was missing. I was using the eGPU to also charge the laptop at the same time. Once I used the AC power simultaneously, I was able to get the eGPU to run in one go. Here’s the step-by-step if anyone else is in this situation:

  1. Disconnect everything from the laptop and eGPU
  2. Boot up the laptop and log in
  3. Connect the laptop’s dedicated AC power adapter
  4. Connect the power cord to the eGPU
  5. Connect the Thunderbolt cable to the laptop’s Thunderbolt port

From there, the eGPU should run and you can safely connect any additional addons that you want to connect to the eGPU.

If I want to upgrade the PSU for my eGPU, how complicated is that? From looking around, it seems I would need a Flex ATX PSU. However, it looks like I’ll need to perform some customization to the GPU case and rewire some things for it to work.

1 Like

Here’s where it starts to get weird, because if you bought this enclosure new and the PSU is the 450W model, that still should be enough. While the Framework uses Thunderbolt 4, your eGPU enclosure should still only be using 3 since it’s backwards compatible, which has a max power output of 100w. From everything I have seen even a full size 3060 ti is rated for 200w. 450w should be more than enough.

Did it deliver power to your older HP just fine, or did you have it plugged into AC as well? If you bought the enclosure refurbished/used it might be worth looking to see if they gave you a lower wattage PSU. You may just need to replace the current one instead of upgrading. Outside of that, I would then suspect something weird with power delivery through the thunderbolt side of things. Trying different ports, different cables, maybe see if there is any difference plugging into the laptop itself instead of the USB-C expansion card.

I’m able to get it to run without the AC as mentioned above, but it take a few tries turning the eGPU on and reconnecting again.

I purchased the AROUS on eBay and I believe this wasn’t modified, but I’ll see if I can get the seller to confirm that with me. They only removed the original 1070 GPU that came with the box.

If it adds more context, I have it connected to an extension cable because I don’t have many outlets in my room. So part of me suspects that it’s not getting the full throttle unless I plug it to the wall directly. Also, my building is very old and I suspect that the electrical setup might be on an older, weaker, system. I’ll need to performs more tests.

Hi guys, I have been rocking an eGPU on my MBP 2019 forever. When I got my Framework back in December, I did the same as I did before. Though It was wonky, it would eventually work. I use to use the top left port for connecting to the eGPU but started having trouble after about a month.

Check my post over here about all the things that have happened (New motherboard, images, video). Maybe check your motherboard on the side you use it the most and see if you are seeing the same thing. After using a different port no problems.

I have never duel charged my laptop, (AC + eGPU) but it is an interesting idea. I’ll try that next week. @ethanosullivan if you are worried about your power get a kilowatt meter and check the voltage and frequency. Or even get a UPS, they will also give you real time info on the power.

Oh and here is my wave magic chicken bit that makes it work for me. (Test on Windows 10 and 11)

  1. Don’t plug in the eGPU till you get logged in. I have had mine just hang either booting windows or during post. (I need to check the lights on the side. I keep forgetting about them.)
  2. Wait till everything is done loading.
  3. Plug in the cable. (These TB3 cables are fragile AF, I got a new cable after the one chip came off, but it did not seem to be the problem. When I had my MBP the OG cable was the cause of all problems I had with it.)
  4. Profit? Oh, I have seen that after plugging it in for some reason the laptop would see it but have it disabled in the device manager.
  5. Bonus! Search your computer for “Thunderbolt Control Center”, or install it from the Microsoft store. It will show you the connect Thunderbolt devices.
1 Like

So you’re saying that the motherboard could also be the culprit? I’m also batch #6 like you.

Let me know how that goes, so far this has fixed everything. I still have to make sure I disconnect everything from the eGPU USB ports. That’s where I have my mic, keyboard, and other cables go through.

Never heard of a UPS, is this what you’re referring to (Uninterruptible Power Supply)?

Just going to throw in my experience as I just got my eGPU working with my Framework last night, and someone else might google this. I did not make any BIOS changes, and I’m on 3.07. Hopefully this will also help you!

eGPU enclosure: Mantiz Saturn Pro v2 aka MZ-03 - Mantiz MZ-03 Saturn Pro EGPU ( V2 ) ( Ship from Feb 18th 2021 )
GPU: Nvidia 3060 Ti (ASUS Dual OC v2) -
Framework 13" running Windows 11

Set everything up, plugged the eGPU in, it started charging and kicked off the GPU fans, Windows automatically installed some drivers, with a warning that the 3060Ti was not compatible with eGPU’s, including a link to the official docs saying as much: Support list for external GPUs using Thunderbolt 3 in Windows | NVIDIA


I thought I had spent a lot of time and money and skipped checking one of the most obvious things. Thankfully a bit of Google-fu and testing and I was able to get it up and running. Initially I could see the GPU through Device Manager, but it was listed as “Display Disabled” with no way to activate. In the following steps I left the eGPU connected the whole time.

Firstly - Download the latest NVidia drivers directly from their website (so it’s ready to go).
Secondly - DDU - Display Driver Uninstaller - DDU Guide / Tutorial | Wagnardsoft the guide isn’t super great, but you’ll get the gist, the app turns out to be really useful.
I used this to uninstall any NVidia drivers and used the option to prevent Windows Update from installing drivers.


Install the NVidia drivers from your previous download, this was successful.

Restart AGAIN (I didn’t do this initially and couldn’t see anything different despite things looking OK)

Upon restart my second display showed the Framework logo, and I was able to configure it as an extended second display.

Final step was to run DDU again just to click the button to restore the Windows Update blocker.

Let me know if anyone wants any performance stats, but I’m just happy that it all worked out in the end.


Just adding my experience here, as another possible solution to somebody else having this problem.
I have a 1280p in a 3d printed case, with an egpu ( EXP GDC TH3P4G3), plugged in to a monitor. Currently I’m testing viability for various uses.
Egpu initially worked with little difficulty, I followed instructions here:

Setup worked well for about a week until,
after updating windows, I could no longer get a signal from the gpu, but I could from the igpu.
Not entirely sure what happened here, but after much unplugging and plugging in and restarting, the egpu appeared to not be recognised, or would appear in the device manager as a hidden device. It would also turn on and off repeatedly, presumably trying to connect. This initial panic may have been my first mistake.

I tried all solutions on this page, and also changed cables. These didn’t work, so after hours of messing with settings in windows that were probably making it worse, I reinstalled windows much to my chagrin, and found that the egpu worked just as easily as the first time, signal worked fine from egpu… However the next time I turn on the framework with egpu (plugged in and on before boot), I once again received no signal. This time, before changing anything, I observed that the egpu was behaving normally, which lead me to believe that it was something more simple.

I had signal again from the igpu, and again could see the egpu in device manager as hidden. In properties, under the general tab, the device status told me I had an error code 45 and to unplug and reconnect the device. I did so, which connected the device properly, however I still could not get signal. An nvidia, prompt came up telling me it was connected. From here I went to nvidia control panel and changed the preferred graphics processor to High-Performance NVIDIA processor, and now I have signal.
If I’d known this in the first instance (not knowing much about egpu’s in the first place) I might have saved myself three days of annoyance.
Just putting this here to potentially save somebody else’s…


How do you connect the TH3P4G3 ?
Direct from USB ? This can be a Driver issue ?
Windows Update is killing me, do you try on Linux ?
Thanks for the review(s)