[SOLVED] Framework 13 7840U w/ Razer Core X 7900 XT

I’m having difficulty it getting the eGPU to work with my Framework and was hoping someone could help. I’m running Windows 11 for my OS and Device Manager doesn’t detect my 7900XT in a Razer Core X. I have AMD Adrenalin 24.3.1 installed, but it only recognizes the 780M series so not sure it also installed drivers for 7900XT or not as they aren’t displayed in the Hardware & Drivers in the AMD software, but maybe that is just because it isn’t being detected via thunderbolt?


Yeah I had to manually install drivers for my intel arc card for it to be recognized so I’d give that a shot, along with rebooting after the fact of course. I’m assuming the card powers up and the fans spin?

Have you tried trouble shooting by seeing if Linux recognizes the card? Since the driver comes bundled with the kernel it should be auto recognized

Any updates? Because i want to use same setup.

Yeah its working great. I didn’t need additional drivers than what I installed for my mainboard l. Just forgot to use the correct cable. Silly me was using a usb-c cable that had charging only capabilities instead of true thrunderbolt.

1 Like

Thank you, can you please run time spy for CPU and GPU results (its test in free 3dMark demo from Steam)?

Please edit title to reflect issue has been resolved @Staten

Not seeing an option for letting me edit again.

1 Like

@moderators could you edit the title to mark as solved please?