(SOLVED) Framework 13 AMD no display but fan and lights are on

Put together my fw 13 diy and the screen is just blank. No signal either when connecting an external monitor via hdmi.
It just sits there with the fans running, no error codes, yes i have reseated ram and storage, keyboard button has the light so there isn’t an issue there either.
I honestly don’t even know what it’s supposed to do. I have a usb stick with ventoy but it doesnt seem to pick it up…??? I’m completely clueless as to what is going on.

Based on similar reports that have been root-caused in other threads, things to rule out:

  • What type of memory? (AMD doesn’t work with 5200MT/s RAM sticks, should be 5600)

  • How much memory? (RAM training on first power up has been reported to take a while - several minutes)

  • If above fails, might be worth trying to re-seat the display connector on the motherboard. See step 6 here.

1 Like

What @dimitris said; also Try a Single DIMM if you have two. The Ram compatibility threads here: AMD RAM issue

and

Note to other users. I reseated the display cables as well; nothing worked… Turns out i just had to let the battery charge, i left it sitting for an hour or so and when i came back and rebooted it, the display came on as normal and it booted.

I don’t know how to mark as solved.

6 Likes

What must a man do to get the attention of the framework tech support? It appears that I am the only unfortunate customer who received a faulty laptop the last week. I tried troubleshooting myself, reseat memory, plugin to external monitor, plugin motherboard to different framework laptop and still no display. I opened a ticket on Monday, and as of today, I haven’t heard back. I would be grateful for any advice.

1 Like

I have the same issue but left it charging and nothing is helping I guess I need to contact support

If you haven’t already. Power it on without the battery. Clean and reseat ram, and try a different usb C port for power

I guess your not the only one Im also unlucky and am waiting for support