[SOLVED] Framework 13 DIY Ryzen - No display

I have been using my Framework 13 DIY Ryzen with Ubuntu 22.04 successfully for the last few weeks. I left the machine in suspend mode unplugged for ~5 days and when I went to power on the machine next the power light came on but no display ever appeared on the laptop display or an external monitor. I opened a ticket with support and their recommendation was to:

  1. Remove the expansion cards and input cover and plug the charger directly to the laptop
  2. Click the chassis intrusion switch 10x slowly until the LED flashes and then hold for 2 seconds
  3. Press the mainboard switch to power on the machine
  4. Observe if the fan spins or if and LED sequences flash

After pressing the mainboard switch I notice that the fan starts to spin, no LED sequence and still no display.

While I wait to hear back from support does anyone have any tips on what else I might try?

I actually am having the same issue, but this happened to me during build. Have not even installed an OS. Will try the steps listed above, thanks.

Did you receive a link with detailed instructions regarding where the mainboard switch is, and where the chassis intrusion switch is? Thanks :slight_smile:

If you are not getting any display (internal) whatsoever, please try resetting the motherboard. Fully Resetting the Mainboard State - Framework Guides

Thanks Matt, are the steps the same for an AMD device? I see the most recent comment on that article stating that the behavior described in the guide does not match what they saw on their AMD laptop.

The AMD laptop doesn’t ship with an RTC battery so I skipped that step. I found the battery connector quite difficult to remove. It only slid out a very small way and wasn’t clear if it was fully disconnected. With those caveats in mind I am still encountering the same issue. No display shown after ~15 minutes of waiting.

Please open a support ticket. This will allow us to dig in on this a bit deeper to get this resolved.

After working with support it appears that something was wrong with the way my bezel was originally attached. Here are the steps I followed:

  1. Open up the case and disconnect the display cable
  2. Reattach the input cover and connect to an external monitor
  3. Boot the system

In my case this display was now being output to the external monitor. Next we looked at the bezel since the problem appeared to be something wrong with the internal display.

  1. Open the input cover and reattach the display cable
  2. Remove the bezel
  3. Reattach the input cover
  4. Boot the machine

In my case my internal display was now functional. Next I tried reattaching the bezel to see if there was just something wrong with my original installation. After reattaching the bezel and powering the machine back on my display was fixed.

2 Likes

Looks like support was able to get things moving in the right direction. Awesome. Appreciate the detailed updates, marking this as resolved.

You are a life saver, I had the same issue

Upon powering up the lapto the first time: black screen.

I had to:

  • Disconnect the internal display connector
  • Insert the HDMI dongle on Port 1 (Port 2 and 3 don’t work)
  • Connect an external display
  • Power On
  • I got display output on the external screen
  • Power Off
  • Connect the internal display connector
  • Disconnect external display
  • Power On

Care:

  • Anti tamper switch on the MOBO triggers blinking red light, it’s not a BIOS status LED
  • Port 2 and 3 had no display out, I was getting disheartened that the problem was deeper


Post again if this issue persists for you. It happens to me every time I leave the machine idle for a couple days. I’ve gone back and forth with support a lot and have made no progress on the underlying issue.