[SOLVED] Frequent reboot / freeze: graphics issue?

My 11th generation laptop (debian linux) sometimes freezes and reboots. Sometimes when this happens, it enters a state where it cannot run: after every boot, it reboots within seconds or minutes (sometimes after login, sometimes at the disk password entry screen, sometimes at the GRUB menu.

Red noise covers the screen when the system freezes (sometimes but not always; visual symptoms vary):

Just once I caught the following error message on the console:

[8.061723] DMAR DRHD: handling fault status reg 3
[8.061807] DMAR DMA Read NO_PASID Request device [00.0d.2] fault addr 0xffffe000 [fault reason 0x0b] non-zero reserved fields in CTP

What can I do to debug this?

Hi @Christopher_White

First remove any attached docks. This allows us to troubleshoot within a vanilla/default environment. Since I don’t know what kernel, custom changes are which version of Debian is installed her, your best bet are the steps below.

Next I would test from a Live USB of your selected distribution. You indicated Debian (which is hit and miss as we don’t officially support it). If the issue does not repeat itself on a Live USB, you can try a fresh install and look to this thread for extended guidance: Debian testing on the Framework Laptop

Thank you!

  1. I don’t have any docks—just expansion ports (2x USB-A, 1x USB-C, 1x HDMI). Should I pull those? (The liveusb is running on one of the USB-A, so I can’t exactly pull all of them…)

  2. I tried a Debian liveusb on Thursday and IIRC got a reboot, but I’m trying again now. What sort of logging should I enable?

  3. I’m contemplating switching distros to something supported, maybe Fedora. (The problem is intermittent, and I’m not delighted about running a liveusb for days or weeks.) What sort of logging should I enable when I do that?

Indeed, the problem shows up on a Debian liveusb.

And on a Fedora 37 live USB—it didn’t stay up long enough even to start the installation.

If you finding this same event happening on a Live USB of Fedora, then something is definitely wrong at a deeper level.

I’d do a last ditch test with Ubuntu Live USB. If this makes for the third distro giving the same error and odd visuals shown in the previous image, this feels like a hardware issue and needs a ticket opened with support.

FWIW I didn’t get the visual symptoms on the Fedora liveusb—I just got the freeze & reboot. But then I didn’t get the visual symptoms all the time on the Debian liveusb, either.

I’ll give an Ubuntu liveusb a try, and if that doesn’t work I’ll open a ticket.

Thank you for the help!

Yep, same trouble with the ubuntu liveusb. Stayed up long enough to install, but immediately after it got to the login screen on the new system, I got bad visual symptoms, freeze, and reboot.

I’m about to open a support ticket.

Are you running from the USB stick or installing to the NVME drive? If it’s stable until the NVME comes into play you might see if you have an issue there, either by running off of the USB stick for a longer time or using a different NVME drive if you have one.

I get the same problem either way.

Based on everything described, yes, please open a support ticket and link to this thread.

Based on the image, this definitely feels like a hardware issue. The support team will be able to help.

Just to follow up on this—I did indeed open a support ticket. They ultimately suggested reseating the memory (or, rather, unplugging it and replugging it per Memory Replacement Guide - Framework Guides )

This (reseating the memory) seems to have worked. It’s a little hard to tell, just because the problem was intermittent, but I’ve been using the laptop for a week now and I grow more confident by the day.

1 Like

Appreciate the update. If it does not, pulling one stick at a time to test also works as it will usually indicate if it happens again with a bad stick. But yes, re-seating can do wonderful things.