Laptop stuck in memory training, won’t boot

I’ve had my Framework laptop for a few months now with no issues. A few days ago when I went to power on my laptop, the side LEDs went solid green and the laptop never booted. I’ve waited over an hour and the memory training doesn’t stop. The fan is also running full throttle and the laptop is generating a fair amount of heat. I decided trying reseating my ram in different configurations, and despite having tried every config nothing has helped. I’ve also done a hard reset (by powering off and removing the battery, and holding the power button for 30 seconds) to no avail. I’ve contacted support already but am in a bit of a rush because I’m moving into college in a few weeks and need my laptop to select courses etc. Is there anything else I can try? I don’t have any spare memory to try using.

Can you get in the bios? I would try just 1 stick of memory if you have 2 and see if it will post. You can also try removing he cmos battery and re-setting!

Fixed it!!! I couldn’t get into bios or anything, had a completely blank screen. Turns out I also had to remove the coin cell on top of the ac and battery, and then it booted up once I put them all back

1 Like

Glad to hear you got around it.