[Solved] Gentoo Touchpad Only Recognized As Legacy PS2 Mouse

I have a 12th gen Framework and am on Gentoo. I was experiencing an issue where the touchpad was only showing up as a legacy PS2 mouse. When I disabled PS2 emulation in the BIOS I had no mouse at all.

Several threads on the internet mentioned enabling random disperate kernel compile options. Some threads also mentioned adding some libinput tweaks. However none of these solutions worked.

What ended up working for me was enabling the specific compile options that the Gentoo Framework laptop wiki page describes:
Navigate to the kernel source directory, run make menuconfig and find these options:

Device Drivers  --->

  Input device support  --->
  HID support  ---> 
     <*> Generic HID driver
     Special HID driver  --->
        <*> HID Multitouch panels
        <*> HID Sensors framework support
     I2C HID support --->
       <*> HID over I2C transport layer ACPI driver
     Intel ISH HID support  --->

         <*> Intel Integrated Sensor Hub

Then build the kernel (if using genkernel be sure to copy the resulting .config to /etc/kernels/kernel-config-{{ version }}-gentoo-x86_64) and reboot.

In hindsight following the touchpad instructions on my distros wiki page for my laptop was the obvious first thing to try. But hopefully the keywords in this post will help future Framework Gentoo folks, or anyone compiling the kernel for this laptop.