Only left click works on touchpad [SOLVED]

I just got my 12th gen laptop (1st batch) and I can’t seem to get any “advanced” functions working on my touchpad on Windows 11. I can only left click, can’t scroll, click with two fingers etc. In Windows settings I can only see sensitivty for the touchpad but no other settings.

I had already gone through another older thread here but it didn’t help. I already installed the framework driver pack and when I disable the ps/2 fallback in BIOS the touchpad just stops working completely. In device manager the touchpad is shown as ps/2 mouse so I suppose I still have to get around that somehow but have no idea how :confused:

Thanks in advance for any help :slight_smile:

1 Like

I know a few people have reported issues, which they resolved through feedback on the forum (reseating the touchpad, mostly). If you’ve already scanned the forum and tried that, I would definitely create a support ticket.

Sorry your first experience came with some speed bumps!!


So you don’t have this

Maybe try:

  • set “PS2 mouse emulation” in bios to “auto”
  • uninstall device in Windows device manager
  • reboot
  • run the driver bundle again

Maybe delete the driver bundle before running the setup again.
Possibly the driver bundle consists of smaller sub setups and you can only delete the touchpad driver by itself? (dont have a framework yet)

Thanks for the replies!

As usual the mistake was on my side :smiley: I managed to install drivers for 11th gen instead of 12th gen that I have. I downloaded the correct drivers now and everything seems to be working :+1:


Damn, had that on my mind too, but forgot about it while writing :sweat_smile:

Good to know you figured it out :upside_down_face:

Hum…For this to happen, there seems to be two gates that failed:

  1. On the download page: How do we make it more obvious so people don’t download the wrong package?
  2. On the driver bundle installation: I thought the bundle already has a check for the mainboard string / identifier…so that the 12th gen bundle only gets installed onto a 12th gen system. (and same thing for the 11th gen). How did the 11th gen bundle get to complete the installation on your 12th gen board in the first place?