[SOLVED] High CPU spikes lagging the system every 1-2 seconds


I bought an 11th gen laptop, and installed Linux (EndeavourOS). I had Linux laptops in the past, but I am facing an issue that I never had before and can’t seem to find anything about it online.

My CPU is spiking to very high usage every 1-2 second, even when absolutely nothing is opened, causing the whole system to lag out. I suspect an issue with the GPU, as this is particularly true when doing tasks that uses the GPU. For example, watching a video is not possible, as it freezes on every spike for about 0.5 second. But this is also true when doing pretty much any task.

I also installed Windows on a dual boot setup, and this issue doesn’t exist on Windows, which tells me it probably isn’t a hardware issue. I also never had this issue before with previous Linux laptops.

Any help would be greatly appreciated!

Does this also happen on the Live ISO? And does this happen on the Ubuntu and Fedora images?

Since you’re running a non-officially-supported Linux distro:
Can you tell us about your kernel and drivers you installed with their versions, and also which boot parameters you’re using and also whether something like tlp is installed and running?

I can’t try the live ISO just now but I’ll post an update later today with live ISOs of Ubuntu, Fedora and Arch. However, I should mention that I already tried to reinstall my system but it didn’t solve the issue.

As for my current system. I am running the latest kernel version available (currently 6.1.9), but it also occurs on the LTS kernel. The graphics driver used is i915, and I should probably also mention that mesa is installed. I don’t really know what else I should be looking for, please tell me if you need more details about this.

TLP is installed and active (it was installed automatically, I have no idea what this does).

I have the following kernel parameters in my grub config: nowatchdog nvme_load=YES nvme.noacpi=1 mem_sleep_default=deep. I also have a bunch of modprobe settings that I recently added, in hope that it would fix the issue (spoilers: it didn’t):
options snd-hda-intel power_save=0
options i915 enable_dc=0
options ahci mobile_lpm_policy=1

Thank you for your help!

Update: I just tried running live ISOs of three distributions (Ubuntu, Fedora and EndeavourOS).

While less significant than on my regular OS, the issue was still present, exactly the same, lagging at the same pace. It was particularly noticeable when I tried watching any video content in 1080p or above (for reference, at 4K, the video is freezing more than it is playing).
But when nothing was running, the lag spikes were seemingly not happening (probably because they were too insignificant to be noticeable).

Sounds like hardware video acceleration is not enabled. The drivers for it are non-free so Fedora for instance does not include them OOTB. Ubuntu might not have them in the live ISO either. You can check if hardware acceleration is working by going to about:support in Firefox and checking if it is working. It should look similar to below where “Hardware_Video_Decoding” is. Ctrl+F to search it instead of scrolling.

TLP (sometimes referred to as The Laptop Project) is a program that helps with battery. It regulates C-states, which you can think of as performance states, the higher the C-state, the lower the power draw (and lower performance) it can also regulate NVMe drives and their power states as well. I recommend reading the configuration file to see everything it does. It’s very well explained, even a tech novice will be able to understand the config file.

Hardware video decoding is enabled in Firefox. The problem is, the issue isn’t in Firefox. It is on the whole system. The lag spikes occurs on Firefox as well as on any other app. Even when nothing is opened, I can feel the lag spikes, for example with the animations on gnome (I should mention that it also occurs on XFCE, the issue isn’t gnome).

How are your temps looking and what’s the clock speed when it lags?

Temps are ok, they never are really high. (no more than 60C/140F)

It seems however that the CPU clock speed is going very low when the lag spikes occurs, at around 200-300MHz. The normal clock speed is at 3.0GHz. I have no idea what could cause this.

Contact Framework support:

1 Like

Thank you very much! I took a quick look at this thread, and it seems that I found the reason why the CPU is lagging: the display port expansion card. While every other one is completely fine, as soon as I plug in the DP one the CPU starts to lag out. I’ll contact Framework support about this issue.

Thank you again for all of your precious help!