[SOLVED] How to disable numpad backlight?

Heya, I unboxed my Framework 16 earlier today. At some point, I pressed some key combination by accident, and now only the numpad has its backlight on.

Fn + Space can be used to adjust the keyboard backlight, but it doesn’t affect the numpad. So, is there a key combination to adjust the numpad?

For the time being, I’ve turned on the keyboard backlight, but I’d rather have it off in the long run.

I know its probably simpler to use Via or Vial to configure things, but A) I’m a Firefox person B) even when I use Chromium, it’s in a Flatpak, which fucks up permissions, and C) I can’t get the Via or Vial AppImages to detect the keyboard or numpad. Maybe I need to mess with some udev rule or something, but I figure someone has to know this keyboard combination, so I should ask before wasting time with udev.

3 Likes

Try this. I don’t have a 16 but pretty sure it’ll work.

  1. Turn off numlock
  2. Press the enter key on the numpad

Source: Default Keymap for the Numpad

9 Likes

Thank you! Worked perfectly.

1 Like

Welcome to the forum.

Note that only Via is supported with the stock firmware. I’m sure someone will port it to Vial at some point, though.

Thank you so much. That did the trick.

(FW 16 running Linux Mint 21.3 with an Edge kernel)

Without having FW 16 how did you know that that would work? Is that something that can be done on other numpads?

You’re very welcome!

Haha good question! Honestly, I just got lucky.

I was flipping through knowledgebase articles and happened to read about it. Then a day or two later I saw this question on the forums, so I shared what I knew.

1 Like