[SOLVED] Monitor no longer works through powered hub

Windows 11 Home
11th gen

I purchased my Framework laptop in early 2022.
I used Plugable USB-C mini docking stations (no link, because of annoying forum rules) for a while for both my Framework laptop and my work MacBook. The Mac had no issues, but the Framework laptop would often have problems - sometimes when I would plug it in to the laptop it would cycle through connecting and disconnecting over and over. Usually after a while, or changing ports several times, it would eventually calm down and work. Then I’d take the laptop somewhere, use some battery, bring it home and plug it in again and problems would recur.

Framework support was useless. Plugable support was more helpful - they even sent me a replacement hub and a Thunderbolt cable to use instead (they believe the problems don’t occur if a Thunderbolt cable is used instead of USB-C). The problems did seem to happen less often, but still I would need to occasionally reset the hub or even swap around the Plugable hubs.

I got a Black Friday deal on a Anker 575 USB-C Docking Station (13-in-1) Anker 575 USB-C Docking Station (13-in-1) and used that with my Framework laptop. I thought that might be working better, although not perfect.

Then recently, my Framework laptop developed a new problem: it won’t connect to my monitor through the powered USB hub. The hub works otherwise - it powers the laptop and my USB keyboard. But the monitor shows a message saying there’s no signal and then turns off.
I tried with the Plugable hub I had used before - same result.
I tried with the other Plugable hub, connected to the monitor’s other HDMI port - it did eventually connect, but the hub kept connecting and disconnecting over and over.
Then I tried connecting the monitor to the laptop using a simple HDMI adapter instead of a powered USB hub. That seems to work just fine (hopefully that will hold up long term).

So apparently, my Framework laptop will connect to monitors through unpowered HDMI adapters, but not through powered USB hubs, and this is a recent change.

I can probably get by by connecting the HDMI monitor in one port and the hub in another port for everything else, but come on - that’s annoying and kind of defeats the purpose of using a hub.

Anyone have any thoughts or suggestions on how to fix this?

Note: I looked at this other thread Caldigit Element Thunderbolt Hub & 4k Display setup - unpredictable performance
I eventually found both Thunderbolt controllers under “system devices” in Device Manager. They do not show the error code 43 cited in that thread; they say “This device is working normally” when the hub is connected but is not communicating with the monitor.

First off, great summary/description of your problem!

Have you checked that all devices have sufficient power? Especially with a hub it’s possible that there is not enough power in the whole setup so devices malfunction randomly.

Double-check if your plug, charging cable and hub all support enough power for your setup to work. For example, if you’re power adapter supports 100W but the charging cable only 65W, you would be limited by it. And if the hub then draws another 20W for its devices (and itself) you have less than 45W left for the laptop left.

Also it would be good to know if the latest setup works with your work MacBook. (And also, which variant it is and how much power it requires, because for example M1 use less power than intels CPUs)

My MacBook (16-inc, 2019, Intel Core i7) works just fine with a Plugable Hub and the exact same monitor. The only consistent factor with the issues is the Framework laptop itself.

Again, I’ll note that having the hub plugged into the Framework (providing power and access to USB devices), while having the monitor connected to the Framework via a basic HDMI adapter and another port works. It’s only when I try to use the monitor through a powered hub (either Anker or Plugable) that I experience problems. And again, the issue with the monitor completely failing through both hubs is recent. The problem is with the Framework laptop itself, as the monitor and the hubs work with other computers, and the computer does not work with either hub.

I tried going through the hub again - and this time it worked! Perhaps the laptop received some updates in the meantime.
The problem was occurring for about a week. It started just before I went on a trip out of town, and I didn’t have time to do more than verify it persisted after a reboot.
I came back from my trip yesterday, still had the issue, and did the testing I described, including trying multiple hubs.
And now today it seemes to be working properly. For now, at least.
It doesn’t seem likely that power consumption would explain this. I’m guessing some kind of software update introduced an issue and then a later software update fixed it, but who knows for sure. I’ll just hope the problem doesn’t come back.