[SOLVED] Interesting Circumstance around missing audio device / Dummy Audio only

Hey guys;

This is regarding the Gen 12 Laptop 13, running Linux (in my case Ubuntu but many others have this problem as well).

I’ve been having no particular trouble with the onboard audio on my laptop since installing Ubuntu, but last night it abruptly stopped working. lspci would show the device, dmesg wasn’t reporting any problems, but it seemed like nothing could ‘talk’ to it. I even went into /dev/snd and tried to poke the devices there and I would get weird errors (sadly I don’t remember the message but it was something like ‘device can’t communicate’)

I went through all the advise on here, re-installing pulseaudio, messing with kernel modules, and nothing helped. I went through many reboots, including ‘halting’ the system and booting up fresh rather than just soft reboots.

I decided to open up the laptop and make sure the audio connection was secure from the motherboard to the sound board. Kind of a last ditch option. When I opened up the laptop, the red lights indicating the motherboard is still powered stayed on and wouldn’t turn off even after leaving it a few minutes.

I booted up, pressed F2 to get into BIOS, and used the option to turn off the battery there. When I exited BIOS, the laptop shut all the way off and the red lights went out.

Then I re-seated my ribbon cable to the audio break out board. It didn’t seem like it needed it, it was well secure. To boot again, I had to plug the laptop in to the power supply.

When I booted up, my audio device worked once again. Hooray! However, I don’t think it was re-seating the cable (though I guess it could have been). I think it was the extra-hard reboot of going through BIOS and ‘disconnecting’ the battery.

I’d like to suggest to anyone out there who’s tried everything and nothing’s worked to perhaps try going into bios, turning the battery off, then booting again and seeing if that fixes your problem. Especially if, like me, it just randomly stops working out of the blue.

Not sure if this is helpful, but throwing it up here anyway :slight_smile:


So this will largely depend on the release of Ubuntu you’re running. Pulseaudio up until 22.10 and higher, then Pipewire.

Nothing needed to happened outside of the OS for dummy audio. :slight_smile:

22.10 thru 23.04 is Pipewire in the guide.

22.04 is still Pulseaudio.

Ctrl F to “Dummy audio or no sound card detected at all” in the guide. This part of the section is a layer lower than the sound server (it’s ALSA tweaks) and just follow along. Be very, very careful about random commands on forums and other websites as many are dated, wrong or simply don’t apply.

1 Like

@Matt_Hartley I actually followed the directions you have linked there, in the section indicated, and at the time they didn’t work. I had no joy until I did the BIOS battery disconnect described above.

I do make sure I understand all commands before putting them in. My system (XUbuntu based on 22.04) had both pulseaudio and pipewire on it for some reason. I left it that way since my research indicates the two can live harmoniously (or pipewire can emulate pulseaudio with pipewire-pulse).

Ah, sounds like you made progress. That’s good to hear.:slight_smile:

You indicated that Xubuntu had both Pipewire and Pulseaudio installed, was this by default? I ask as they can conflict pretty hard. Either way, I am very happy you were able to get it resolved.

Yeah! I got it working, and so far (knock on wood) no issues. And yeah, I believe it was by default. Either that, or something I installed brought the other one along for the ride and I didn’t notice it. Admittedly, I wasn’t paying close attention to it until I had a problem.

That said, I hadn’t installed anything recently when the problem started, so it’s been that way for awhile.

1 Like