[SOLVED] No output/input devices found, audio input/output missing in device manager

I had audio issues since today and i am so beyond desperate to have audio back- I think inm missing omething? the " Intel High Definition Audio Driver for Windows 11" but all i find is realteck or something else that never works. PLEASE HELP!!!

i have tried downloading so many different audio drivers. nothing. still nothing detected

You have tried using the official Framework driver bundle?

i have, yes, and now im aware that there is no audio in my device manager (audio input/output missing in device manager)

i am down on my knees at this point please help in any way possible

@Mercy Take a deep breath, it’s going to be alright. I want to help and I’m going to try but have you also reached out to Framework support as well? Have you verified the connection for the audio board is good? Have you tried booting into Safe Mode? What steps have you tried?

1 Like

ive tried the update drivers, but none were found. i cant even access sound because thats gone, no idea why that happened. I attempted to download realtek audi drivers from the intel site but no dice, as well as the driver bundle from frameworks.

i sent an email last night, but no reply yet

i also tried a full reset, nothing

Just to make sure… you uninstalled all other drivers and tried reinstalling the official ones after?

Also did you try Windows system restore?

i went to a repair place and they reinstalled it from a usb. while the audio now works- the touchpad is now nonfunctional

and yes, i reinsalled and restored beforehand

Hi Mercy,

Framework Support only respond on weekdays, so they should hopefully get back to you tomorrow. Until they do, I would recommend posting the model of your laptop (11th or 12th gen) here so that we can better help you. You mentioned that you installed and reinstalled the driver bundle, but I am curious if you may have accidentally installed the wrong one? There are separate bundles for the 11th and 12th gen boards. You also keep mentioning realtek drivers, but only very early 11th gen boards use realtek chips, and new laptops these days use Tempo Audio, which uses a generic driver. (I have one of the realtek boards, so I can’t give you an example of what the tempo board would show in the device manager).

Either way I hope you can get your issues resolved!

1 Like

@Mercy The Tempo audio codec (used in later 11th Gen Intel Core Laptops and all current 12th Gen Intel Core Laptops) uses standard Windows audio drivers. The only mainboards that required dedicated drivers were ones with RealTek audio, and those were only the very early batches of 11th Gen Intel Core Framework Laptops. After the reinstall of Windows, you’ll want to install the appropriate Framework Driver Bundle (as @Azure) mentioned. If after the install, you still can’t use the touchpad, you’ll want to remove the Input Cover and see if the touchpad cable has been damaged in any way. If the ribbon cable was removed and reinserted improperly, it can cause a short.


Issue was solved with a fresh install of Windows from a drive. (I went to Micro Center, great place)