No Audio Output Device is Installed

Hi - I bought the DIY and installed the drivers. During drivers install, it stopped on a line that said there was no audio codec. It said to press any key to restart and continue installing. But when I restart, nothing appears to continue to install. I’ve tried 3x.

My laptop says there is no audio output device installed. Windows audio troubleshooter could not find an audio device.

I have Windows 10 and installed the 10/29 drivers. I tried searching for older drivers since it looks like 10/29 is in beta(?) but I couldn’t find older versions.

I then installed all windows updates. There was one for Realtek. I’ve restarted my laptop a lot but nothing is fixing the audio issue. I also unplugged and replugged the keyboard cord and also checked that all other cords are secure inside.

Device Manager shows Other Devices > Intel High Definition DSP with a yield icon. The properties say the drivers for the HD Audio Bus Driver is not installed. I tried adding legacy hardware to find old realtek drivers but those wouldn’t install.

That’s everything I could google. Any ideas on what else I should try?

Can you make sure the audio board is plugged all the way in? You can use this guide: follow up to step 5 and then from step 9 onward (since you’re not replacing the audio board).

1 Like

Thanks for the instructions @Chiraag_Nataraj! But unfortunately, that didn’t work. I tried taking both sides of the cable completely out and replugging them in. Tried twice with laptop restarts both times and the audio device is still not detected.

Hmm, idk what to do in that case. I was trying to see if the UEFI settings display the audio board when it’s connected, but I don’t think so.

1 Like

@Chiraag_Nataraj Thanks for trying! Hopefully someone on here maybe had the same issue and can provide insight. :confused:

1 Like

Hi, please try to reinstall windows10 using fresh windows installation media from Microsoft. This should help get the missing drivers & codecs for the device.

Re-installing Windows OS is NOT the answer. IMHO that is a lame excuse like just “reboot” or “unplug then re-plug”. I have 2x DIY FrameWork Laptops and one has audio then the other does NOT. I would like to see the FrameWork Driver Pack broken out to individual drivers. I know that 7Z can unpack the Driver Pack, however, I don’t know the file name that I am after. Any help on that?