External Monitor has no signal

Hello guys,

i want to use a cheap portable monitor with my new Framework Laptop, but sadly i can’t get it to work. Here are the basic info’s:

Framework 13 AMD
Windows 11 Pro
The portable Monitor ist connected via USB C cable and according to the amazon page it should be compatible with TB 3.0, USB-C 3.1 and Type C DP Alt-Mode.
Display Resolution 1920x1080

When i plug in the cable, the monitor will get power and show that it has no signal, after that it switches to power save mode.

I know that the monitor works with the included cable, i tried it with my samsung tablet, works fine.
I already tried to use different cables, different USB-C modules and different slots for the modules, every time the same result.
The monitor ist not listed in the display options of windows.

I even tried to use a live installation of fedora, doesn’t work either.

Maybe not related but I connected the Laptop via HDMI to another montitor, which works fine.

Maybe you guy’s have a solution to this problem, i already checked other threads, but somehow every listed solution doesn’t work for me.

Which slot are you connecting it to? Slot 2 (The one nearest to you on the left) has no display output.

I tried every slot…