[SOLVED]Lighdm not recognizing the GPU on Ubuntu 22.04 with xubuntu-desktop

Hi everyone,
I just installed the xubuntu desktop on Ubuntu 22.04 and during the installation process selected the lightdm option as I prefer it over gdm3. I rebooted the install to check everything was ok but got a bit of a shock when the loading stopped on an error saying lightdm does not recognize the GPU and could not start.

With lightdm selected in Ubuntu and this error occurring I then couldn’t get into Ubuntu. Fortunately I have a dual boot with Xubuntu 22.04 in a separate partition. Interestingly enough lightdm works absolutely fine there and there is no problem for it recognizing the GPU. I booted into it and in a terminal chrooted into the Ubuntu root partition and ran the command …

sudo dpkg-reconfigure lightdm

… from where I could then select GDM3.

After a reboot everything is ok and I am now logged into the xubuntu desktop session from the Ubuntu GDM3 log in screen. However I’m baffled as to why lightdm in Xubuntu works fine with the gen12 GPU but does not recognize the GPU when set up with the xubuntu desktop session on Ubuntu.

Has anybody here been successful in installing the xubuntu-desktop into Ubuntu and selecting the lightdm greeter screen rather than using GDM? Or alternatively does anyone know any reason why Xubuntu with lightdm is OK but Ubuntu with the xubuntu desktop session and lightdm is not OK with the GPU hardware?

I will have to experiment a bit tomorrow and see if what I tried will work the opposite way around with the ubuntu-desktop session installed into the Xubuntu install. I would like to have both sessions available in the one install with access from the lightdm greeter. I do know the risks/cons of doing such and have be doing such setups for about 10 years now.

Edit: This is now solved, sorry everyone. I was following the guide…

… and in step 2 when using the command nothing happened. After that command not doing anything I then used apt rather than tasksel; this is where my trouble started. I have since run the tasksel command (without any package specified) and installed the xfce package and re-ran the dpkg-reconfigure command above and set lightdm back … It works now.

@moderators, please check this thread/post and if you see fit remove it or if it is of any use I’m happy to leave it here.


1 Like