[SOLVED] Linux Mint Grub Issues

Hey Y’all

I just got a Framework laptop yesterday and I’m setting up linux mint on in. I followed the install instructions and after changing the grub settings to make the brightness up/down buttons work I restarted and am now unable to access the terminal. If I open the UI in the ‘cinnamon (defualt)’ mode when logging in the screen is just black and if I got into the ‘software rendering’ mode then the ui works normally but if I click on the terminal applet it attempts to load (the mouse becomes the spinny wheel) but it never opens the terminal. It’s a bit difficult to do anything in linux without a terminal so uh asking for a bit of help here. any ideas?

Solved! It actually ended being a python issue. Gnome-terminal was unable to open because of this error

  File "/usr/bin/gnome-terminal", line 9, in <module>
    from gi.repository import GLib, Gio
  File "/usr/lib/python3/dist-packages/gi/__init__.py", line 40, in <module>
    from . import _gi
ImportError: cannot import name '_gi' from partially initialized module 'gi' (most likely due to a circular import) (/usr/lib/python3/dist-packages/gi/__init__.py) 

This was caused because I updated my python to 3.11 from 3.10 and not all the dependencies swapped over. I fixed it by running sudo update-alternatives --config python3 and setting the default to 3.10