[SOLVED] Need "nomodeset" to boot Linux, and extension ports malfunction

I’m having a little bit a problem right now with my 12th gen (i7-1280P):

I cannot boot Linux anymore.
The M.2 SSD contains an Artix distro, with a kernel that was booting fine until recently, but now when I boot it is stuck at “starting udevd”:

I tried with a linux-lts kernel (a 5.15 kernel), same thing:

I tried to boot Ubuntu on a SDCard or a USB, but it wouldn’t even appear in the F3 or in the F12 menu, as if it was not recognizing the devices anymore.
EDIT: it does appear in F3 and I can boot it, at the condition that the sdcard reader is the only extension card plugged-in (as I use a Live Linux on a microSD).
However, the Live Linux is then stuck around the same stage as the main SSD’s Linux.

I tried removing one, then the other RAM (each time putting the one in the slot 0), but that doesn’t make any difference.

I tried without the SSD, just with sdcard or USB, but then it behaves just like there was no storage at all.

I tried to remove the main battery and the RTC battery for 10 minutes, and it did reset my BIOS settings, but the problem was still present.

I have an old 11th gen with Windows on it, and I tried to put its Windows SSD on the 12th gen: it boots Windows.

I tried to put the 12th-gen’s Linux SSD in the 11th-gen, and it boots Linux.

I’m completely clueless to what I should do (except contact Support, which I’ll do [I just did, waiting now])…

Which BIOS firmware are you using? Did you double-check if all connections are clear/good and nothing is bent and alike?

Did the laptop overheat before this issue? Did you see any damage on the motherboard or other components?

1 Like

I’m on the latest 3.06, to which I had upgraded without any problem (and I was using that for several weeks now).

I have looked thoroughly when I opened it, and I saw nothing weird except maybe some white dirt on a little cubic component (I’ll try to take a photo shortly).

I don’t think it overheat, but I did have something weird just before: suddenly a USB-C cable that I was using did not work anymore (and the laptop failed to charge, I failed to notice, and it run out of battery), so I used another cable (different brand and maybe different specs) and I discarded the old as defective. But after that I rebooted fine and used a bit more the machine.

This “PLX1” component had a bit more white dust on it, but I removed most of it with my finger.

Just thinking out of the box … did you try removing all the expansion ports and booting it up without any? Or at least a single USB C expansion port to rule out issues with the PCI lanes and/or motherboard/power issues?

1 Like

Yes I tried without any extension, but it was the same.

OH! You are onto something!

I just tried with only 1 extension card, the sdcard, with a bootable XUbuntu on it. At least it can see the EFI from XUbuntu and I can select it in the F3 menu!

But then I get the same-ish infamous screen:

… and the bootable ISO is working on the 11th gen laptop, right?

Because I had ISOs with wrong checksums which never booted.

Also, it would be interesting to know if modifying the intel BIOS settings to DISABLE all the internet power settings changes anything.

1 Like

Yes the iso works, as it worked also on the 12th-gen before the problem started.

What do you mean by internet power settings?

I’m sorry, I meant the Intel Power Settings.

Powerboost, Powermode, etc.

1 Like

Yes I had deactivated “Quick boot” and “Quiet boot”.
As for Powerboost I have not touched it, but it seems to boot Windows just fine as it is.

Right now I have exchanged the SSDs with my SO (who was using the 11th-gen), so that I can have the 11th-gen now and have some work done on Linux.

She just told me that it works fine for her on the 12th-gen with Windows.

Except that she cannot use the extension ports anymore for anything else than just charging the laptop, but I expect this could be solved by installing the drivers pack for the 12th-gen (because her SSD has the 11th-gen drivers pack).

I haven’t given up on helping you yet, however I need to spend more time on thinking about possible ways how to combat this issue first though.

One more thing I would check is if there is a change for only seating one ram slots, if you have multiple.

1 Like

I really really appreciate your help!!!
This is what is really making the difference, comparing to a standard laptop: the right to repair, but also the immense community behind!

RAM: I did that, I tried removing one RAM, then the other (and then the remaining one always needs to go to the slot 0, I know).


I wonder if the problem can be the SSD: it’s a SN850.
But then why XUbuntu on a microSD would also get stuck during the boot sequence? (maybe because the SSD is still inside the machine?)
Also, why the issue would start to happen suddenly, while for months all was perfect?

EDIT: no it’s not the SSD, as I have the same problem with another SSD model.

Some new element, I noticed that I had a blinking POST code at boot:

White (10 seconds), Green X 12, Orange, Blue, Blue, Green, Blue, Green, Green, Green

which seems to mean 0x17 or “BDS_CONNECT_CONSOLE_OUT”, i.e. “video device initialization”.

But I have no idea how to use that information.

BTW I am in contact with Support and I provided them all these informations.
They have replied to me and are working on the case.

If you want to, you could try removing the “quiet” kernel parameter. There should be a lot more text on the screen, possibly indicating that it gets stuck at some other point.
Press e in the grub menu, go to the linux line and remove the word “quiet”, press ctrl + x to boot.

1 Like

Ooh yeah, that’s a lot more information!
But I fear that what came before this screen is lost.

Thank you a lot for this tip!
Although I’m unable to take advantage of these new data… do you see anyting that stands out?

Here is another attempt while taking care to add the i915.enable_psr=0, just in case it would change anything:

Yeah this is useful in telling us that the last thing happening is i915 aka Intel graphics driver doing something. This seems relaxed:

Although the outcome isn’t all that positive… You might try Ubuntu “Safe Graphics”, maybe it works and see if you can replicate what was seen in that thread.

1 Like

Ouch. Exactly the same thing.
Likely a hardware issue too, then…

Many many thanks…

I’m in contact with Support, I’ll see soon.