[RESPONDED] 12th gen i5 DIY linux ubuntu 22.04 won't charge or turn on

Yesterday my laptop turned off suddenly. I booted it back up, but noticed that I could only charge from one of my three usb-c ports. At the end of the day, I noticed that the charge had stopped at some point and I had been running on battery power. I rebooted and the system failed to come on.

When I press the power button, it lights up for 3-5 seconds, then turns off. The light beside the card slots would blink green several times. However, now that doesn’t even happen. If i leave the laptop for a long period (+30m), it sometimes turns on and boots properly. However, once it sleeps or powers down it fails to restart again.

I have tried several steps, based on tips found here, but the laptop will not charge and now I can not get it to turn on. What i have tried:

  1. I have tried multiple AC power cables in multiple outlets and confirmed they work with other devices. I have also switched around the USB-C cards to try all cards in all slots. Result: when plugging in, no “charging” lights appear by the card slots.
  2. I unplugged the battery and plugged it back in. Result: no change.
  3. I followed the steps to reset the mainboard status. Result: after taking out the RTC coin cel, unplugging the battery, and plugging in the AC power, no red lights flashed. After plugging everything back in, no change.

I have contacted support. But this is my only work device. I am really hoping to resolve this as soon as possible. Thanks for any advice or suggestions.

  • Which OS (Operating System)? Linux
  • Which release of your OS (Operating System / Windows 10, 11, Distribution of Linux)? Ubuntu 22.04
  • Which Framework laptop (11th, 12th or 13th generation Framework laptop) are you asking for support with? 12th gen

Welcome to the community @Nate2, sorry to hear you’re experiencing this.

You did the right thing by contacting support as it sounds like this could be hardware issue based on what you’ve tried.

As a total last ditch effort to get this to be able to power on until support can take a look, and also realizing lighting is nil and showing no signs of life.

  • Attach to power with a known to be compatible power adapter.
  • Noting there is no lighting showing charging, let it sit for a bit.
  • Press the power button. I have seen instances where in some cases this brings the laptop to life, but you may have a hardware issue where this isn’t happening.

Thanks @Matt_Hartley. Yes, if I leave the laptop for a while (30+ minutes), it will boot up. However, it is still not charging when it loads up. And as soon as it sleeps, it can’t be restarted again for another 30+ minutes.

I noticed this time when I booted it up that the status LEDs flashed. It was all white except two. It was red/orange on the 8th and 14th flash and blue on the 16th and 20th flash. If I understand the table described at My Framework Laptop (Intel 12th Gen Intel® Core™) is not powering on, this means:

  • 8th flash red: no audio board detected
  • 14th flash red: start of “post code section”
  • 16th flash blue: post code bit 1 = 1
  • 20th flash blue: post code bit 5 = 1

I found some data about the post codes here Post code bits meaning - #5 by Usernames but i don’t know if they apply to my laptop generation. I’m also not sure how to read them.

Finally, I found at the bottom of [knowledgebase]/my-laptop-is-not-powering-on-ryQLXvQkt that there is a problem with the RTC coin cell in 11th generation laptops that could put the processor into a stuck state. I didn’t leave my laptop unplugged for long periods, but is it possible this could happen because the RTC coin cell itself is busted? I tried the steps to reset the mainboard state but that didn’t work. I’m also not sure if it would explain why the AC charger isn’t charging the battery.

Still waiting on an initial reply from support. I took it into a shop today and after talking through what I’d done they thought it was very likely a motherboard issue.

I tried plugging in AC power directly to the usb-c port of the card slot, instead of through the port in the card. After a boot up, I was able to get the battery to charge off of one of the four card slots. I tried to reboot and it failed as before.

I’m still within warranty, so I am considering buying a motherboard and returning it if needed. I currently have a 12th gen i5-1240p. That’s out of stock at the moment. Would you recommend I do the 12th gen i7-1260 or the 13th gen i5-1340p? I’m leaning towards the 13th gen in the hopes that there are fewer issues…

Sorry. My reply was wrong. I mixed 2 pages… And refurbished options seems to be only in the USA.

1 Like

Checked, it’s in the queue. We’re all coming back from the holiday weekend, looks to be in the appropriate queue. Expect to hear back in the very near future.

1 Like