[SOLVED] No drives found for Windows Install. IRST not working

Hi everyone,

I just got my DIY framework laptop with downloadable Windows 11.

When came the time to install Windows 11 (using the Media Creation Tool on a USB key), I got stuck in the setup process.

At the step: “Where do you want to install Windows?”, there are no drives in the list to choose from. It says: “We couldn’t find any drives. To get a storage driver, click Load Driver.”


  • Using another USB stick
  • Turning it off and on again :stuck_out_tongue:
  • Downloading an Intel Rapid Storage Technology (IRST) driver through Asus.com,
    But it did not work. The Framework doesn’t recognize it when I browse for a driver.
    It does not appear on the list, unless I uncheck the box that says: “Hide drivers that aren’t compatible with this computer’s hardware”. And when I do, the IRST driver still doesn’t work. A progress bar goes up to around 90%, three or four times, very quickly, and then nothing happens?

Is there any IRST that is better compatible with the Framework? I couldn’t find any on the website.
Or else, is there any other diagnosis, or another solution besides IRST to find/loada driver and setup windows?

Thank you so much everyone. Looking forward to use this beautiful machine.

EDIT: I have lookied into this [Solved] thread. I’m a noob, might have not understood everything, but it does not seem to be the same problem: his solution was to download the media creation tool using a Windows machine, which is already the way I did it.

Is the drive installed properly - i.e. fully seated in its slot, no contact traces visible?

Is the drive visible in the BIOS? You may need to select boot order “first” or “last”, not “auto”.

I’m not a Windows expert, but you shouldn’t need IRST.

Thank you for the fast reply @Fraoch !
Noob here.
How can I select the boot order and show the BIOS?
What are “contact traces”?

For the BIOS keep tapping the F2 key as you are powering up then you will see a menu and you shouldn’t find it difficult to find the Boot options.

I imagine the ‘Contact traces’ are the metal contacts on the NVMe and RAM etc. If you can see them the implication being that they are not seated fully.

1 Like

There was a fantastic photo of improper installation of an M.2 SSD on here, but I can’t find it.

When an M.2 SSD is properly installed, you should not be able to see any of the gold coloured “fingers” that insert into the socket. Someone on this forum found they didn’t insert the drive all the way but could push it down flat and screw down the retaining screw - it looked right but was not detected. The only sign was that the traces were visible.

Here’s the right way:

The traces should be fully inserted into the socket before you press the drive down. You may have to push to the right a bit harder than you expect. When you push down you should feel the socket contacts act like a spring wanting to push the drive back up.

1 Like

Maybe this one :slight_smile:

1 Like

That’s it! Thank you @amoun!

1 Like

You guys are lovely! It was the SSD contact indeed.
Thanks a whole lot!


That’s great! I thought it was a stab in the dark, but glad it helped!

1 Like