Windows not locating drivers on Framework 13 DIY AMD

I have a Framework 13 AMD Ryzen 7040 and I opted for Windows 11 when I bought the device. I’m moving from MacOS, so it was a little complicated but I was able to get the Windows installer up and running. However, the computer won’t acknowledge any of my drivers. I have made sure they are the drivers from framework’s website. Regardless, the laptop won’t pick up any divers (I tried intel drivers just to see) on an SSD or Flash Drive. Both were formatted to ExFAT so I’m a little lost. I did put UBUNTU on the laptop after my failed attempts just to see if it worked and that works fine. I have attached pictures of the error and flash drive.


Use the partition manager, create a partition and format it with a valid filesystem?

Hi and welcome

You should just be able to click on the download and all relevant drivers should be automatically installed, it’s an automatic executable file, so just click on it once it’s downloaded.

You cannot load the Framework drivers during setup.

You typically only need to load drivers during setup if you have an unusual storage situation and Windows can’t find your main hard drive.

If you are unable to find your NVMe drive on the Framework Laptop, it is not due to missing drivers. Try booting without Ventoy (its disk emulation makes the Windows installer unable to detect the main drive.)

Once you’ve installed Windows, then you can install the drivers.

2 Likes

The NVMe does appear when I hit browse, and I didn’t use Vetony to create a bootable. I used a series of commands I found online, then balenaEtcher when I ran into this error. Would you mind elaborating on what you mean by unusual storage situation? It also seems as though I have an out of date BIOS version (3.03 instead of 3.05). I assume this would need to be updated but I don’t know if Frameworks have a UEFI option.