[SOLVED] Power Surge on the USB Port [Windows 10, DIY 1185G7]

A few months ago I had this same issue and it resolved itself after about a day of time powered completely off, but now it’s come back. I am getting a persistent, repeated notification on Windows that there is a power surge on the USB port. Even when nothing is plugged in, even after reboots, shutdowns, switching to my Ubuntu install and back, etc. I have it on video this time, find that here.

I’m running Windows 10 on a DIY edition 1185G7. I’ve also had an issue since I got the laptop with one specific pair of USB headphones taking 20-ish seconds to start working, but I don’t think it’s related because this is a new issue.

1 Like

What BIOS version are you on? I started seeing this error a lot on version 3.10

I’m on whatever the latest one is, I believe that’s 3.10.

Edit: yes, it is.

What do you mean the same issue, this is a new topic of yours and the only one to post??

The latest BIOS is 3.17 for the 11th Gen

1 Like

I contacted support but the issue resolved itself the first time. I’ll try the beta when I get home.

Am I safe in marking this thread as resolved?

No, the current issue is ongoing. Almost ready ti head home and check the beta bios.

1 Like

I forgot to update here, BIOS update worked. Also, I got a message back from Framework Support, a reset of the mainboard is known to fix the issue. The instructions I got from them:

Our apologies for the issues.

We’ve seen this occur in rare instances, but it should be resolvable by doing a full reset of the mainboard. You can do that by following the steps below:

  1. Plug the power into the laptop and keep it plugged in for at least one hour.
  2. Unplug power.
  3. Open the system following the guide here. If the LEDs are blinking red at this point, make sure to wait until they turn off.
  4. Carefully pop out the RTC battery (the coin cell) with a pin following the steps here (the holder is pretty fragile, so definitely follow the method in the image).
  5. Wait 15 minutes, and then carefully re-insert the RTC battery.
  6. Close up the system, following the guide.
  7. Plug in power and press the power button.

Great! I’ll mark this as resolved.