"Power surge on the USB port"


I have a Framework 13, 11th generation. Worked well so far, but today, Windows told me I have a “power surge on the USB port”, even though only the charger was connected. I tried various things, none of which have removed the message (if I dismiss it, or try the suggested “reset”, it reappears):

  • Disconnecting the charger
  • Removing all expansion cards (it was only USB-C and USB-A inserted)
  • Reboot.

I am on the latest BIOS v3.19, all Windows 11 Updates installed, all optional updates and drivers up to date. Nothing wrong in Device Manager.

In the end, after the 3rd reboot, the issue disappeared. I’m wondering if it has been experienced before, to know what to do in case it comes back (this message is intrusive). I can see one instance before, where it’s been solved by a BIOS update. Another suggestions was resetting the mainboard; does this reset cause any issue? I am travelling for work so can’t do much reinstall at the moment.


When I experienced this it was because the RTC battery was going bad. Resetting the mainboard is a fix to other RTC battery issues in 11th gen Intel, but as the guide notes if the issue reoccurs you may need to replace the RTC battery. If you reach out to support and describe the issue they will generally provide a replacement RTC battery.

Since you’re traveling I’d leave the laptop plugged in whenever possible to ensure the RTC battery is fully charging (it does not charge from the main battery) or else this issue will likely reoccur.

My experience with the issue was that a bios update to the same version I was already running fixed it.

Thank you both. I will bear this in mind if the issue reoccurs - so far, not.
Sorry for the noob question: does resetting the mainboard cause any loss of data? For instance do I have to re-set a few BIOS parameters afterwards?

Thanks for the clear and detailed post.

I just ran into this problem on my 11th gen 13". Following the steps for resetting the mainboard appears (after 40 minutes of no problems) to have resolved this issue.

Thanks to all for these posts.

< david