"Overvoltage on USB port" message on Windows 11

I sometimes get a message that says “Overvoltage on USB port” and does not go away:

Text from screenshot translated with DeepL:
Windows Explorer
Current overvoltage at USB port
“Unknown USB device” needs more
than the port can supply.

If I click on the notification I get this window:

Text from screenshot ttranslated with DeepL:
A USB device is not functioning properly and has exceeded the power limits of its hub port. You should remove this device remove it.
Disconnect the device from the port and click “Reset”. If you click on “Close”, the port will no longer be functional until you disconnect the until you have disconnected the device and restarted the PC.
Reset Close

None of the options change anything. This also happens with no expansion cards in the usb slots it usally resolves when I shut down the Laptop and wait while.

Most of the time I do not have this problem, but when it occurs the message pops up again and again.
Has anyone an idea what could cause this behaviour?

Device Information:
-Windows 11
-11th gen i7 framework
-Bios 3.19
-Pine64 60W charger
-1xUSB-C, 2x USB A, 1xHDMI

The first thing that occurs to me is the little EMI shield stickers on the back of the USB C ports on the mainboard. I would check to make sure those stickers aren’t applied incorrectly and intermittently shorting out the ports.

I would also take a look at the ports closely to make sure there are no foreign objects inside or bent pins.

1 Like

In my case this was related to the RTC battery going bad, a common issue on 11th gen Intel. Doing a mainboard reset would temporarily fix the “Power Surge on USB port” notifications, but it would eventually return until I replaced the RTC battery. In my case this was also accompanied with typical RTC battery issues such as the system clock being wrong or at times failing to boot.

In the short term, I would try a mainboard reset as indicated in the first link, not neglecting the last step of leaving the laptop plugged in for 24 hours to let the RTC battery fully charge. 11th Gen Intel only charges the RTC battery when plugged in, so if the machine is only plugged in briefly and intermittently this problem is more likely to occur. If the issue returns I would definitely reach out to support; they are a bit swamped right now, but they can confirm the issue and potentially send a replacement RTC battery. Note if you choose to source a replacement RTC battery yourself, you will need a rechargeable one such as a ML1220 3V battery. Framework has a guide for a more permanent fix but it requires soldering.


@reverse_thrust My Framework is plugged in most of the time.This problem goes away when I shutdown the laptop and wait a while. I also have not noticed any of the other issues related to the rtc battery(I will try to look for them now). The last time this happend was today, after I updated my bios (3.17->3.19), after the reboot the message appeared, rebooting did not solve the issue immidiately, but a shutdown and waiting did. I will now try the suggestion of @BigT and look at the emi shields.

I could not see anything wrong with the emi shield or the ports.
Something I have not mentioned before is that I have set the charging limit to 75% in my bios. After the bios update my battery charged over 75%, until I activated the charging limit again. Since waiting solved the issue it might be the case that the drop of battery charge solved it.
Could somebody try if that replicates the issue?

I got this message when I accidentally tried to put the charger cable into a USB-A port. I exchanged that USB-A card for another and the error went away