[SOLVED] Remove stripped screw on bottom cover

I just finished assembling my DIY 13" AMD Framework Laptop but I need to open it up again because the power button won’t light up.

After one uncareful attempt to remove the bottom left screw (the one that’s supposed to lift the input cover) it stripped so badly, that I can’t unscrew it anymore. It still looks decent (see attached picture) but my Framework screwdriver can do a full rotation without moving anything.

Are there any ways to remove the screw without damaging the rest of the device?

I’ve already tried the rubber band trick (didn’t work) and it’s too flat to use a plier.

I have the same issue on all of my screws. Contact support

@Aquatica Did they tell you anything?

I received an email tonight of them asking if it was an out-of-the-box issue, pics, and the conditions of the package when I received it. Still waiting for an answer.

@Aquatica For me, it wasn’t an out-of-box issue, but something I caused myself for not being careful enough, so I’m not sure if warranty covers this.

1 Like

Are you sure you caused this and it isn’t just a bad screw? Reddit - Dive into anything

Mine wasn’t an out-of-the-box issue either, the screw just stripped itself because it’s stuck.

Yeah, it being a cheap screw was probaly part of the problem, but I could’ve avoided this. I will contact support now. How long did you have to wait for a response?

@Aquatica are you u/ponyaqua on reddit, or do they just coincidentially have the same problem as you?

4 days without counting non-working days

that’s me

@Aquatica Can you please notify me when you hear from support again?

Sure!

i guess there are endless (videos) instructions etc on the web to remove stripped screws of all sorts and kinds and environments.

the rubber band attempt comes to my mind quickly, i was able to remove screws that way often. remove the damaged screw (if possible) and report to frame work support and let them deliver you a set of new screws etc.

good luck.

1 Like

@Ben_Kaps they just asked for pics of the screwdriver

1 Like

Is there a way to ‘reset’ captive screws? One screw in my laptop makes a ‘clicking’ noise when I try to screw it into the laptop body. I think it maybe due to the pitch of the screw being misaligned, but I am not too sure.

It’s not too much of a problem but if it is any easy fix that I could do by myself, i’d like to do so. If anyone has some tips, I’d be grateful!

@abittner As I already said, rubber band doesn’t work. Pliers don’t work either since it’s flat, so I might have to invest in a screw extractor kit.

i think i have seen some folks solder some little lever to metal stuff to be able to exercise larger leverage or force in such situations? dont take this advice too seariously though i am not an expert, dont hose your hardware.

@Ben_Kaps They forwarded my ticket to “the staff responsible for further review”

I bought a new, higher quality T5 torx screwdriver and managed to remove the stripped screw easily without any other special tools.

6 Likes