[SOLVED] Touchpad Ub. 22.04.2 LTS not working, did I do something bad?

My touchpad is not working, and I cannot remember whether it has always been this way. Settings>Mouse & Touchpad has no touchpad settings, gsettings looks normal. I tried running Fedora from a USB stick and I have no touchpad control.

qrp@Laptop:~$ gsettings list-recursively org.gnome.desktop.peripherals.touchpad
org.gnome.desktop.peripherals.touchpad click-method ‘areas’
org.gnome.desktop.peripherals.touchpad disable-while-typing false
org.gnome.desktop.peripherals.touchpad edge-scrolling-enabled false
org.gnome.desktop.peripherals.touchpad left-handed ‘mouse’
org.gnome.desktop.peripherals.touchpad middle-click-emulation false
org.gnome.desktop.peripherals.touchpad natural-scroll true
org.gnome.desktop.peripherals.touchpad send-events ‘enabled’
org.gnome.desktop.peripherals.touchpad speed 0.0
org.gnome.desktop.peripherals.touchpad tap-and-drag true
org.gnome.desktop.peripherals.touchpad tap-and-drag-lock false
org.gnome.desktop.peripherals.touchpad tap-button-map ‘default’
org.gnome.desktop.peripherals.touchpad tap-to-click true
org.gnome.desktop.peripherals.touchpad two-finger-scrolling-enabled true

rp@Laptop:~$ xinput
WARNING: running xinput against an Xwayland server. See the xinput man page for details.
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ xwayland-pointer:16 id=6 [slave pointer (2)]
⎜ ↳ xwayland-relative-pointer:16 id=7 [slave pointer (2)]
⎜ ↳ xwayland-pointer-gestures:16 id=8 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ xwayland-keyboard:16

qrp@Laptop:~$ hyfetch

Host: Laptop AB
OS: Ubuntu 22.04.2 LTS x86_64
DE: GNOME 42.5 (wayland)
Kernel: Linux 5.19.0-35-generic
Shell: bash 5.1.16
Resolution: 2256x1504
WM: Mutter
CPU: 11th Gen Intel i7-1165G7 (8) @ 4.7GHz
GPU: Intel TigerLake-LP GT2 [Iris Xe Graphics]
GPU Driver: i915
Memory: 4.00 GiB / 15.41 GiB (26%)
Disk (/): 28G / 228G (13%)
Network: Wifi

Happy to help. If you’r experiencing this both on Ubuntu installed and on a Fedora Live USB, triple check the cable connection. Physically detach and re-attach it. Check all your connections while you have it open.

If it’s still not working, the connection, touchpad or similar may need additional troubleshooting. If it’s failing still, I’d contact support and link to this thread. Framework | Support

The keyboard cable is firmly attached, still fails.

Thanks for the update. Please reach out to support and let them know this was tested on both an installed Ubuntu install and a live Fedora Live USB, it’s something at the hardware level.

Please contact support and link to this thread. Framework | Support

1 Like

FW replaced the touchpad, everything works fine now.