[SOLVED] Ubuntu 22.04 tap still clicks with tap-to-click disabled

After upgrading from 21.10 to 22.04 my Tap-to-click setting is no longer respected.
I like the setting disabled, yet tap issues clicks. Tested by very light taps on the top of the touchpad, which does behave as if I had depressed the button area.
Would like ideas for what else to check for misconfiguration.
The configuration seems correct, as per libinput list-devices:

Device:           PIXA3854:00 093A:0274 Touchpad
Kernel:           /dev/input/event7
Group:            5
Seat:             seat0, default
Size:             111x73mm
Capabilities:     pointer gesture
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   flat *adaptive
Rotation:         n/a

libinput-tools/jammy-updates,jammy-security,now 1.20.0-1ubuntu0.1 amd64 [installed]
Linux 5.15.0-40-generic #43-Ubuntu

What is the DE?

If there are settings configured on the user level, they will override the system settings. Check mouse/touchpad options in system settings (in the GUI), or dotfile configs in your home folder.

That is a good point. I forgot to provide that bit of info. I am using Gnome on X11.
I did check before posting the gnome settings and both the UI and dconf have the tap-to-click as false. A quick grep yielded nothing relevant. Any additional ideas?

$ egrep -rIin 'tap.to.click' .[a-zA-Z]* | grep -v bash_history
$ dconf read /org/gnome/desktop/peripherals/touchpad/tap-to-click 
$ gsettings list-recursively org.gnome.desktop.peripherals.touchpad | grep tap
org.gnome.desktop.peripherals.touchpad tap-and-drag true
org.gnome.desktop.peripherals.touchpad tap-and-drag-lock false
org.gnome.desktop.peripherals.touchpad tap-button-map 'default'
org.gnome.desktop.peripherals.touchpad tap-to-click false

I switched to Gnome on Wayland and now the setting works as expected.

I did have quite a bit of instability on Wayland where the session would crash occasionally, which was resolved (so far) by :

$ gsettings set org.gnome.shell.extensions.dash-to-dock show-mounts false
1 Like

As for the X11 solution this is what did it for me was to create the following in /etc/X11/xorg.conf.d/99-synaptics-overrides.conf:

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "Tapping" "off"

The key part was adding:

       Option "Tapping" "off"

This does allow for the setting pane to enable Tap-to-Click (WIN!)


I had spoken too soon about the Wayland instability.Another source was (still with dash-to-dock) when both “Show window preview on hover” and “Show tooltip on hover” are on, as I started noticing the Wayland crashes also clustered around the cursor hovering on the panel.