Touchpad doesn't work under Xubuntu 24.04

Touchpad is completely unresponsive.

However, it worked during the installation process. Which is very odd.

Any ideas?

Could you plug in a mouse and check the mouse settings? Maybe it disabled it for some reason?

Running Xubuntu 24 on my lenovo laptop and touchpad works fine. I have run 22 on a framework 13 without issue.

Probably related to the problem introduced in some of the more recent kernels. Try rolling back to an earlier kernel.

I’m having a similar issue with KaOS (Arch) but it is only an issue on reboots (warm starts) and a shutdown then start works.

I did this and the touchpad started working. Then shortly after stopped again (er, wasn’t really paying attention to what I did, I was concentrating on getting DP ALT over usb-c to work, which it did after reordering some expansion slots.)

Since then I tried:

  • Ubuntu 22.04 (worked)
  • Xubuntu 24.04 (a second fresh install – busted still, though the installers live cd still worked)
  • Ubuntu 24.04 (worked)

When it was broken, there were missing pointer devices under xubuntu as listed by xinput listWhen it works there are two “PIXA3854” devices.