[SOLVED] Ubuntu 22.04 Touchpad overly sensitive

Does anyone else find the touchpad to be overly sensitive in normal use? I disabled the touchpad while typing, which fixed the random clicks and cursor movements I was experiencing. However, I’m still having a persistent issue with the touchpad registering scrolling after I do dragging tasks (selecting areas of text or moving items in a Google Slides presentation).

I’m not new to Ubuntu/Xubuntu, but most of my experience is on desktop. I have used GalliumOS, which was a well-optimized version of Xubuntu for Chromebook hardware. I never found the touchpad to be near as finicky using that OS and other hardware.

Thanks in advance for any advice!

Hi @Nick_Anderson,

Appreciate you indicating that you’re an experienced Ubuntu user.

This is very odd. A few quick questions to regarding this:

  • Do you have any extra GNOME extensions or browser extensions installed that might affect how the touchpad operates?
  • Is this a new occurrence after a system update?
  • Is this a new occurrence after opening your Framework laptop up to adjust/replace anything?
  • Which kernel are you on? Using uname -r in the terminal is fine.
  • Are you using Wayland or Xorg?

Hi @Matt_Hartley,

My workaround was to lower the touchpad sensitivity. That, combined with disabling the touchpad while typing, appeared to address my concerns about the touchpad.

Unfortunately, I ran into several other issues with Xubuntu 22.04 and have since swapped over to Ubuntu 22.04. Most things are much better under Ubuntu 22.04 - except for a WiFi issue at work. However, this means that I can’t give answers to your questions directly from my machine.

I can say that it was the standard Xubuntu 22.04 install, updated to the most recent package versions, with the only change being an installation of the Brave browser. I don’t think any of my extensions would have caused the issue, but I can no longer test this as I’ve changed the OS.

I also can’t confirm Xorg vs Wayland or the kernel. I believe Xubuntu 22.04 ships with Xorg and 5.15. I did not change between Xorg and Wayland or update the kernel.

I have a 12th gen i5 DIY Framework laptop. The issue existed from the first time I used the machine.

Typing from my 12th gen Framework on Ubuntu 22.04 right now. XFCE (Xubuntu) may be doing something creative with the touchpad, difficult to be sure.

Disabling while typing is a must if using the laptop keyboard, glad you have that enabled.

I generally disabled two finger scrolling for presentations and use edge scrolling as to prevent any surprises.

@Nick_Anderson You can probably recreate the trackpad issue you are having if you switch back to xorg in the login screen (the gear icon on the bottom right when you log in lets you switch between wayland and xorg). I noticed a weirdness to the trackpad when I switch to Xorg to see if a certain program worked. Wayland has been much better at dealing with the trackpad than Xorg.

Very true.