[SOLVED] Ubuntu won't boot, hangs when displaying logs

  • Which OS (Operating System)?
  • Which release of your OS (Operating System)?
  • Framework laptop (11th or 12th generation Framework laptop) are you asking for support with?
    12th gen
  • If this is a Linux issue, please use the Linux tag or at least put Linux in the title.

Hi, this is a clone of my post on reddit: https://www.reddit.com/r/framework/comments/12bnt7d/ubuntu_laptop_wont_boot/?utm_source=share&utm_medium=android_app&utm_name=androidcss&utm_term=1&utm_content=share_button

Hi, this issue started happening a few minutes ago right before my next class which is very unfortunate. I’m new to Linux so I’m sorry if I use any improper terminology.

I have Ubuntu version 22.10, gen 12 Intel CPU.

I closed my laptop, unplugged it, and put it in my bag as I walked around for a few minutes. I open it back up and the fingerprint scanner fails, and I weirdly can not enter my password nor click on the field to enter it.

I held down the power button to force shutdown. When I started it again would not get past the short log that happens during booting. Here’s an image of what it looks like: https://cdn.discordapp.com/attachments/339563014476922880/1092842625956053002/IMG_20230404_114937.jpg

I’ve tried to hold down shift when turning it on to access GRUB but nothing different happens. Having it plugged in during boot also doesn’t change anything.

If anyone is able to give guidance on what to do that would be greatly appreciated. I don’t have another computer to flash firmware to at the moment unfortunately.

Additional info:

After waiting for a while, another line will appear saying

[xxx.xxxxxx] cros_ec_lpcs cros_ec_lpcs.0: bad packet checksum

I’m able to enter boot manager by tapping F12 while starting and I can see Ubuntu as an option, but launching it from there causes the same issue

I’m able to enter the F2 menu during boot, I turned off quick boot and that did not change anything.

under setup utility I’m able to disable wifi and Bluetooth which makes the final log go away, but it still hangs

I’m able to enter GRUB boot menu. I was told to delete the words “quiet” and “splash” from the boot options. It still hangs, but here’s what it looks like after: (link redacted due to limit)

I needed to reinstall ubuntu-desktop, here’s how I did it:

  1. Power on the laptop and keep tapping F4 until you enter the GRUB Boot Menu or whatever it’s called.
  2. Go to Advanced Options for Ubuntu, again it might be called something a little different.
  3. Scroll to an option that says (recovery) at the end of the listing and press enter.
  4. Wait for the magenta screen with a list of options to show up, then select the option that says “root” and says something about going into a terminal or bash or something.
  5. Figure out how to connect to the internet through terminal commands
  6. run sudo apt update, sudo apt upgrade
  7. run sudo apt-get install --reinstall ubuntu-desktop
  8. then sudo reboot
    At that point it booted successfully.


That’s very unfortunate, because the information you gave us is not very helpful (not trying to be evil, just saying that its all fine for now) so you cutting off the probably only lead I could get is very unfortunate.

I would suggest running a Live-ISO and then mounting the drives and repairing the install from there. For me it looks like by force-shutting the laptop down something broke, maybe a bad file in initrams or alike. So the first thing I would do is try to regenerate my initrams from a live-ISO.

1 Like

Hi, here is the image. It doesn’t seem all that useful to me but I don’t know what I’m looking for either.

After a bit of Googling it looks like the graphic server does not start.

Can you switch to a console (CTRL+ALT+F2) and perform a bit of cleanup:

To fix broken packages on Debian-based distributions using APT:

  • sudo apt --fix-missing update
  • sudo apt update
  • sudo update-initrams (to regenerate the initrams)
  • Reboot and check if its fixed!
1 Like

Hi, we ran
Apt --fix-missing update
Apt update
Apt upgrade
Update-initramfs -c -k 5.19.0-38-generic (update-initramfs isnt a command so we consulted google for this)

sudo reboot

The same issue continues to occur. The idea that the graphics server isn’t running does make sense to me though.

Apologies for the poor formatting, I am on mobile.

I managed to find a post detailing roughly the same issue I’m having. Doing sudo apt-get install --reinstall ubuntu-desktop then reboot and that worked! Thank you for sending me on the right path with the gui not starting.


Hey, that’s great to hear that you got it working again!

Let’s hope you wont need this knowledge anytime soon again! :slight_smile: