[SOLVED] UEFI Setting to disable S0 Sleep

@bmcdonnell - I just tested this on an 11th gen running windows 11 and the registry edit worked. Make sure to run regedit as administrator, and that you add a dword 32 bit value. Then close regedit, reboot, and you should see standby (s3) available.

Good luck!


I did. It isn’t. [EDIT2: see update below.]

EDIT (winver):

I never claimed Framework is “blocking” anything (least of all S3). Windows by default prevents use of S3 when S0 is available, and MS is making it increasingly difficult to utilize S3 (when S0 is available). As explained in the LTT video (link in OP), MS has iteratively removed several easier ways to enable S3. How long until they break this registry hack, too? Or have they already, partially?

You could tell me you understand my initial suggestion that if Framework could provide us an option in the UEFI/BIOS/firmware to prevent the OS from using S0 (not S3), then we’d have the most reliable way to force Windows to use (fallback to) S3 for sleep.

Instead of arguing against this feature request, which would presumably be no skin off your back.

That’s a bit harsh after all a) you are asking for help b) the Topic has been SOLVED so c) your ask maybe that you want Framework to do what you want but as this is a user forum other people are engaging with you to the best of thier abilities.

I can look for ways to impliment but not moding the BIOS for you. :slight_smile:

So this is where I’m at: Learn Microsoft

To disable modern standby, set the following registry key and reboot.

reg add HKLM\System\CurrentControlSet\Control\Power /v PlatformAoAcOverride /t REG_DWORD /d 0
Disabling modern standby can impact power consumption when the system is idle.

Confirmed along with @bmcdonnell below
Of interest maybe

@bmcdonnell - see it any of the other steps in this article help: https://appuals.com/disable-modern-standby-windows/

Hopefully one of them works. If so, please do let us know what the magic formula was.

Good luck!

Ugh. Well, I still think the retracted feature request from the OP is worthwhile. But I did get the registry hack working.

Apparently I had included a stray character (space or backtick) when I copied and pasted the registry key. (You can’t tell from the screenshot.) Deleted, recreated, rebooted, and it works.

Apologies for the confusion.


@bmcdonnell - thank you for the follow up, and glad that you got it working. Have a great evening (or day, or morning, or whatever is appropriate in your neck of the woods)!

Simple question.

So S3 is enabled but how to invoke it ?

Using the common ‘Sleep’ option it looks like it goes to Hibernate but with the power button flashing. Uses no dicernable power but takes 14 seconds to wake, exactly the same as Hibernate.

Removed regedit mod and back to S0

This Sleep invoke in the same way does do an instant power on with any key, which it what I would expect and uses about 1 or 2 watts when sleeping.

Sounds like a good way to get MS to blacklist FW from getting PK keys and breaking Secure Boot. Whether you like it or not, MS has power here. Besides, your “cure” would impact Linux users as well, an undesirable behavior for me at least. If you don’t like what Windows does and it pisses you off so much…don’t use Windows. Use Linux or Mac. I’m not trying to be a jerk but asking FW to fix what MS does is ridiculous.

1 Like

If I may interject, I do support adding a UEFI toggle to disable S0 sleep. It’s my understanding that more than one UEFI supports that already, so why would Microsoft go after it?

1 Like

Seems at first glance like a good idea to add a toggle to BIOS, since theoretically it’ll force Windows to use S3. But as of right now S3 performs worse than hibernate…

1 Like

This seems like you’re finally engaging with my actual argument, so thanks for that. Why do you think that MS would do that? Again, my suggestion/request here has only been that they provide users an option to disable S0, not that they make this the default behavior.

How would it affect anyone who doesn’t toggle the setting?

I’m working on it.

Yeah, I’m learning this. :frowning:

I believe you invoke it manually with Start → Power → Sleep.

For me, with the S3 registry hack, it takes an unusually long time to come back to life (~12-14 sec, vs. e.g. ~4 seconds for my old Thinkpad), but it doesn’t appear to be going through a boot sequence when waking, as it does with hibernate. Also, it requires an extra keypress / mouse movement to wake the display. So I think it is actually some sort of sleep–probably S3–just badly implemented. (IDK who’s at “fault”–e.g. MS/Windows, some firmware, some driver, Intel, etc.)

Additionally, when waking from (presumed) S3, it does a terrible job of rediscovering my USB-C dock and its connected resources, requiring 2+ disconnect/reconnect cycles. So this may not even really be usable for me.

Yes I didn’t realise, before I made the reg changes, that it replaced the common ‘Modern’ option.

Yes a real mess, good job Framework didn’t waste rresources offering it in the BIOS as there would have been lots of complaints that is was worse nhibernate.

So yes happy to have hibernate and S0 for the odd moments it can be useful.

Al the best.

Ah, I misunderstood that part then. If it were the default behavior it would impact Linux users. As for MS…why do they block S3 sleep at all? Perhaps they would take no action at all or remove FW from authorized distributors of Windows or blacklist the PK or whatever. I’m for user freedom but I’d rather they put the engineering dollars into Coreboot than paying Insyde to develop that feature. It’s not that I’m opposed to what you want per se, just that I think you bark up the wrong tree as it were.

1 Like

Given an above, and my experience S3 is a waste of time, slower and worse than hibernate.

Must get someone else to try on a lapto[p other that Framework

Well, I retract my vote for the feature request (for BIOS to prevent modern standby).

On further reading, I’ve found several claims (1, 2, 3, 4) that Intel and AMD have removed support for S3 sleep in their newer processors/platforms, and that supposedly S0iX states (“modern standby”) are to be its replacement. I’ve not yet found a clear admission/explanation of that from Intel or AMD, though.

However, it’s so obviously not a suitable replacement. No one at Intel ever put their laptop to sleep and put it in their backpack when they were considering these changes? Standby and sleep do not mean the same thing.

I don’t need “instant on” from a proper “sleep” state. What I do want from it:

  • Silent and safe to block airflow
    • All moving components stop - especially fans
  • Quicker entry/exit vs. hibernate (S4 / suspend to disk)
  • Wakes only when I tell it to; not when the OS does because it wants to do who knows what tasks that it just. must. do. immediately–NO, they can wait until I wake it


(Modified from source.)

I don’t need, want, or expect my laptop to behave like a mobile device. It still doesn’t, and can’t, even with “modern standby”. I’m not saying there’s no use for it, but at least Microsoft’s implementation really sucks, in that sleep isn’t sleep anymore.

I suspect/hope that various Linux distros have saner “sleep” implementations, i.e. enter and stay in S0i3, fans off, until actually awoken by the user.


1 Like

I have my laptop to hibernate when the lid is closed.

Annomaly 1W
  • Enabled sleep from menu/start
  • I read 1W usage on my 12V ‘mains’ system with a 1W light on ???

Will check a few more times

Not consistant.

11W to 14W
  • Now the power button doesn’t flash, it stays on
  • The screen goes off
  • It uses more power than when idle, from 11W to 14W ???

Twice now: If I hibernate and then select sleep from the menu/start

  • The power button flashes
  • power useage 3W

The laptop is never ‘switched’ off but if I have been using it from hibernate for some time the ‘sleep’ function does the above

I disabled s3 sleep in the command line, but the issue persists for me. I found my laptop with a dead battery today after closing it while it was plugged in. A bios toggle would really help still. How do I ping the moderators to undo the “solved” label on this topic? It’s not solved.