Windows install on Framework 13 7040 - without an existing windows machine


My wife just got a Framework 13 7040 (at my urging), but purchased the DIY windows version and we have run into something that appears to be fairly frequent on the forum but I haven’t found any solutions that work:

Has anyone come up with a way to successfully create functional Windows 11 install media without an existing Windows machine?

We are currently a Mac* household, and so far I’ve tried following the ‘Framework Windows 11 Installation on the Framework Laptop 13 AMD Ryzen 7040’ guide up to the point we’d downloaded the media. Then writing that to a USB stick using Balena Etcher because the suggested software to write it requires windows.

This got us to this error: [Solved] Windows install - blocked at "A media driver your computer needs is missing."

Which it seems is probably a problem with the way that Balena Etcher handles writing the ISO.

Then eventually** I tried wimlib*** (from this: )

That got me to an installer, but now I’m stuck at: ‘Windows Setup couldn’t create a new partition or locate an existing one’

I’ve tried several fixes for this, but I’m now at a loss. I’m not sure if this is a file corruption during the splitting / copying process issue or a windows-installer-on-framework issue. We haven’t even managed to get to the known problem with it not having a supported wifi device yet.

We do have friends with Windows, but it’s a while 'til we can see them to try writing the USB stick using the media creator, but if anyone has any suggestions this it be really helpful.


  • We have a linux box, but it’s a headless server located in a loft space so not one I can lay my hands on to use to create media.
    ** Just to document other things I tried to save others the hassle, I also tried running the Windows Media Creator using Wine. It did not go well.
    *** Although the instructions there didn’t work for me because it kept crashing during writing, so I ended up splitting the files on my Mac’s harddrive, then copying them across.

I have NO idea if this will work but, Rufus through WINE?

1 Like

You could use VMWare Fusion (free) or VirtualBox to install Windows in a VM and then use Rufus from there (as per Framework instructions). A lot of work to create a USB installer, but might be the only way if you can’t get to a Windows machine.

Have you tried just using dd from the terminal? For macOS or OS X or whatever it should be something like dd if=/path/to/windows_iso of=/dev/disk{2} bs=1024 where {2} is whatever your USB drive is actually represented by on your Mac. You’ll need to run it with the sudo command or from the root user.

I didn’t try DD - one of my friends who has a framework did, and no, there’s something odd about the format of the ISO which means that doesn’t work.

Rufus on Wine doesn’t seem to want to detect the USB stick which is probably a wine configuration issue. I also can’t seem to get a the current version to load at all (wrong windows version error), although Rufus 3.22 looks like it might be feasible with more work.

Thankfully a friend with Windows has offered to make us a USB stick and is available later today, so I think that’s going to be the solution.

1 Like

Greetings. My question about this: if I use my purchased-from-FW windows key in Virtual Box, can I then use the same key to install windows on my FW 13? Thanks in advance. Happy holidays.

I would assume the key you get from FW is an OEM key and is not easily transferable. But assuming VB takes the key and talks to MS’s servers, no you’d need a separate key for the laptop (or whatever doesn’t have the FW provided key.)