Storage expansion card not bootable/booting?

I got a FW13 AMD with an storage expansion card, I wanted to try installing an OS on it, I did but the card does not show up in the BIOS as a bootable drive.

What am I missing?
Thank you.

It’s possible for the installer installed the bootloader onto the internal drive. Try removing the internal SSD and install then OS with the expansion card the only SSD installed

Welcome to the forum

Which OS, and what did you use to install it? It may not have installed right. You can try reinstalling.

1 Like


Thank you for your answers.

I tried Linux ubuntu & OpenBSD…

But I am speaking about the BIOS here… when I plug any USB drive (like one for installation), it shows up in the BIOS as a bootable disk but surprisingly the storage expansion module does not appear at all.

It was recognized as a target drive when I boot my installation medium (either Linux or OpenBSD), installs fine, GPT partitions are created include the EFI partition needed but for some reason it does not show in the BIOS ever…

I don’t want to scream “it does not work” because I probably miss some understanding or miss something, so I wonder if you guys see the storage expansion card in the BIOS EFI section?

People have posted that they boot off storage expansion cards.

yes, I’ve seen, multiple people saying they have booted of expansion storage module.

I am trying to understand why i do not see it when booting, I am wondering if they see their expansion card from BIOS viewpoint, if yes, then something is going on here on my fresh FW13.

hope someone will let me know :slight_smile:

It’ll only show up as a boot device if there i something to boot on it.

Right, thanks for that, I did not know.

I always expected the BIOS to enumarates the hw device (despite their bootability or not) AND THEN to “parse” the disk boot records, whether they’re EFI/GPT or MBR and fail in the second part when actually trying to boot.

Indeed the BIOS seems to read (and parse) the boot records of all devices during enumeration even before starting to boot.

I just made a quick experiment, with BIOS booting new devices First (will test with Last and Auto after) with a blank USB drive where the boot records are completely messed up (like dd if=/dev/urandom of=/dev/raw_device), the BIOS freezes on the framework logo at boot :slight_smile:

I’ll dig when I have time, anyone knows if the UEFI code is available?

anyway, I got to see the device now after reinstalling.

another funny thing, depending on when you press F12, sometimes it shows up, sometimes not… am i the only one having that?

but if the BIOS is on “boot new devices first” it does boot from the expansion card every time, no issues there.

Thanks for your help, super community here it seems!

1 Like

Pretty sure that’s how it worked in the bios days. These days it just looks for partitions with the right flags and tries to run efi files.