Support page on website not working from Australian end

Hi, i have received a new Laptop13, Intel Core i5. it wont fire up. I cant submit a support request as it fails to submit the request after the captcha bit. Anyone else know if the website hasn’t worked for last 2 days?

Was it new, and DIY or prebuild?

If DIY maybe check through all the steps for getting everything connected, just in case something arrived loose.

I didn’t encounter this with mine of the same spec. Hopefully the support page part gets sorted quickly!

Hi Marc
It was new and prebuild

What browser are you using? Have you tried it with a different browser? Sometimes Firefox can have issues that can be resolved by trying on Chrome. Hopefully someone from the support team can also look into this.

Was using Chrome, also tried MS Edge and submit doesn’t work.
Tried emailing support direct but replied to use support request!
So cant contact them

Try clearing your cookies.

Id say try Firefox (or safari if you have a mac) since Edge is now Chrome based and this could be a Chrome issue, but also try clearing your cookies like @Josh_Cook said. If those don’t work hopefully a staff member sees this or the mods can let them know!

Did all that
Finally got a staff member from US to notice and they are now following up with Aus as to why not working.

1 Like