ReCaptcha blocking me from submitting a support ticket

Hi Framework team,

I’m having a minor issue with shipping so I tried to contact your support.
Despite the fact that I’m logged in with my account, which has a valid order, I still have to pass the ReCaptcha on your support form. I’m visiting your website in an anonymous window and Google isn’t happy with that, so I can’t get a pass. The worst part is, because you’re using ReCaptcha v3 and the way you configured it, I don’t even get a chance to pass ReCaptcha by selecting cars/traffic lights/bikes. Also, when I tried to refresh the page and try again, all the content I typed was lost. Effectively, as a paid customer, I have no way to access your support.

I understand that you have to fight spam and there’re technical challenges to properly implement a support system, but when your customer tries to contact your support, he/she is not in a good mood, and being unable to contact the support is just 100% frustration.

Thank you


As for the initial issue, I’m in France and just got the tracking number for my order. The problem is that there’s only a number, without the courier shipped with, I can’t track the package with only a number.

Disable your Browser Extensions like AdBlock.
Helped for me

Ya I had similar problems as well, but after 3-4 retries it usually works!

@Holocrafted @Animesh_Sahu Thanks for your reply.
It would be the best if Framework team officially addresses the issue, instead of frustrated end users trying to find a workaround.

I disabled any browser addons that may interfere with it, and tried 3 times, that didn’t help. ReCaptcha v3 is a black box, I don’t want to spend 30 minutes to find a way out, nor does other less technical customers want to or are able to.


do you have some kind of screenshot of the problem?

You have to disable your adbloquer.

After clicking Submit:

(and everything I typed is gone)

Hi dz1,

This error is typically caused by adblock extensions/software or js-blockers as it is in place to avoid nefarious spam attacks and concurrent submissions. Do you have either of those enabled in your browser by chance?

1 Like

I created an exception for pop-up blocker for It still failed, but then I was presented with the captcha and then was able to submit. Thank you

@TheTwistgibber Thanks for your reply

As I mentioned in the thread above, I’ve disabled any browser extension that may interfere with ReCaptcha, I ensured that ReCaptcha was properly loaded and no network request was blocked, tried 3 times, still didn’t get a pass. Maybe my browser or IP is too suspicious to Google.

I’m not writing this thread to look for a workaround, the reason I wrote this thread is a call to fix the issue on your side. It’s reasonable to require a captcha for a user without an account, I understand, but what’s the point to require a captcha for an account with a valid credit card and an ongoing order to contact your customer support?
Please consider passing my concern to your product team.

Thanks a lot

Hello dz1,

We are unable to disable ReCaptcha as that would leave our systems vulnerable to attack/abuse. While this may be affecting you, the vast majority of customers are successfully able to submit support requests. If you are completely blocked from submitting based on your browser settings, etc., you can submit a ticket directly via and we will be able to respond.


It’s kindda confusing, this public forum is more vulnerable to attack/abuse than a support system, however there isn’t any kind of captcha to publish a thread on the forum. Anyway.

Thanks for the email address, it’s way easier IMO and much appreciated!

Have a good day

1 Like