DIY Framework hard to install without internet access. EDIT: SOLVED

Well, managed to put the laptop together, not too bad overall. However, as I did not pay for OS, I was going to install Windows 7 Ultimate off of a DVD or using Rufus, off of a USB stick. No go. The laptop is a brick right now. Made a bootable USB stick, same problem. The message I get is "Default Boot Device Missing or Boot Failed.


do you have the bios set for legacy? and the ssd as the first boot device?

When I turn on the laptop, it does not show me any way to get to the bios or set boot device. Just a blank screen and then it turns off.

If I put an external USB stick or DVD drive in, I get that error message.

There are threads about booting… And any issues.

“a brick is only a brick if not placed properly”


Additonal… without a usb stick in, when I click on Fn F5, I get that same message.

Hopefully these steps help. Try turning the laptop off, let it sit for a minute, then when it turns on repeatedly hit F2 to get to the bios settings. If you are able to get into the BIOS, check that secure boot is turned off, then shut down, insert the USB stick, and turn it on again. On the very first boot the screen stays black for a while as the ram is verified. I didn’t realize this and wondered what was going on, but it did eventually boot, and I later learned about the RAM verification. If it still will not boot, make a note of the light sequence on the left side between the expansion card slots. You can check what it means here: My Framework Laptop is not powering on

Good luck, let us know how things go.

1 Like

I’m betting this is a Secure Boot issue.

Secure Boot is enabled by default, and Windows 7 is pre-Secure-Boot, so you’ll need to disable Secure Boot in the BIOS before it’ll want to boot off that install media.

See the BIOS guide thread for more details/screenshots, but in summary, F2 during startup (press it a bunch when the screen is on but blank or framework logo is there) to get into the BIOS settings, “Security” tab, then “Secure Boot” sub-heading, then set “Enforce Secure Boot” from Enabled to Disabled.


Thanks to the both of you. It seems that the RAM was slow to load. I am now looking at the BIOS (Thanks for the FnF2 sequence. Will try again with my Rufus USB Boot

1 Like

Wrong. It is still a brick. I am about to give up and send this thing back. Secure is turned off. Bios still won’t recognize: W7 DVD, W7 bootable USB, W10 bootable USB.

The exact sequence is this: Using, for example, the USB stick created by Rufus, the laptop recognizes it now that secure boot was changed, it shows a bar loading and it says it is starting windows. Fine, or so I thought. The little stars that should be moving to show installation is ongoing are frozen and a half hour later, nothing.

@Nicholas_C_DeBord I would suggest creating a bootable usb using the windows tool at

Windows 7 is too old for this hardware, so I would not recommend even trying it. Windows 7 has not been supported on newer intel CPUs since 7th gen. That 4 generations of CPUs from Intel!
We have a handy guide for you to follow:


@Nicholas_C_DeBord one thing you could try is powering down your laptop fully, removing AC then wait 1 minute and power it back up again and see if you can boot into the windows installer.

I will try removing the AC and see. As for trying to install, I have tried W7 DVD, USB W7 and USB W10 (all set up with rufus). None worked.

Hi Nicholas, please make sure to use Microsoft’s Windows Media Creation tool. The setup flow at Windows 10 Installation on the Framework Laptop DIY Edition - Framework Guides is the one we recommend, as we’ve tested it internally and it is well proven by many of the folks in this community also using it successfully.


Media Creation Tool failed. Tried again after removing the AC temporarily and used Rufus W10 20H2 v2 USB . This works, a pity I could not use Windows 7 Ultimate which I have used successfully before on Acer and Dell laptops. Can’t have everything as the upgrade path from Ultimate to Pro is still there without having to purchase a Windows 10 Pro license. Will now through FrameWork???



Got windows installed, can’t run wifi though, it doesnt’ see it. Airplane turned off.
Will restart the router and see if that is what is going on.

All connections are secure, nothing loose. Any advice on why Windows says there is no WiFi?



If you are running windows 10, have you installed the driver package here: How do I download drivers for my Framework Laptop?

Much thanks, did that and it all works. The problem was I had to borrow a neighbor’s laptop to download files. This Framework is, for the moment, the only working computer here.

Got the files and installed everything. Seems to be perfect so far. Downloading the necessary files was impossible

Excuse my slowness with this. I go back to the IBM System/360, entered commands mainly with a teletype keyboard.



Nick, could you do us a favor and change the title of this thread? As your Framework Laptop was never a brick, I feel it unnecessarily misleading.

Part of Framework’s mission is empowering everyone to have more control over their computer. The steps you have gone through here I’m sure have helped you to do that very thing. However, the framework laptop worked flawlessly based on what I’ve read here.

Glad you got it working! I’m sure you’ll soon see how stellar this laptop is!