Thunderbolt not working after 12th gen upgrade

I was using thunderbolt perfectly fine before upgrading my board. 12th gen driver pack said nothing about thunderbolt when installed. I even ran the 11th gen driver installation, tested the eGPU, installed the 12th gen drivers AGAIN, and tested the eGPU. Nothing I do can get the eGPU that I know worked perfectly well on my 11th gen board to work on my 12th gen board. I thought this was supposed to be an upgrade, not a downgrade.

Have you written to support and asked them about this? If you have not please do that, as they will be able to give you better and presumably quicker support than posting here and hoping a community member can help.

I think this is important to just verify that you are using the correct driver packages, what operating system you are using, etc.

I really hope you get a speedy solution and get cranking on the new 12th gen. Mine should be getting here any day now as well.


Did you start with a clean installation or just dropped in your 11th gen Windows install?
Maybe something did not uninstall correctly and now your drivers are messed up…

Thanks, I just did.

Regardless of something UNinstalling, the 12th gen drivers should include a version of thunderbolt that works with 12th gen just in case. The fact that they don’t is concerning. If they are expecting people to come from an 11th gen board and use the Thunderbolt driver that the 11th gen board does, me installing 11th gen drivers and then installing 12th gen drivers should have fixed that.

I guess you mixed something up there!?
Does not make sense to me. :frowning:

Because the 12th gen pack doesn’t have Thunderbolt, the only Thunderbolt drivers would be from the 11th gen. Reinstalling the 11th gen pack (and therefore the only Thunderbolt drivers Framework provides) should have fixed any installation errors for Thunderbolt, the only thing I’m having a problem with. Installing the the 12th gen drivers after that (which don’t include Thunderbolt) would upgrade the rest of the drivers to the current board’s version, eliminating any non-Thunderbolt driver issues that would potentially be interfering with Thunderbolt (USB3/4 perhaps?).
Any issues that stem from 11th gen based Thunderbolt drivers not working with 12th gen would be fixed by having a more compatible version of Thunderbolt in the 12th gen’s driver pack. The fact that they don’t means that they expect 11th gen Thunderbolt, the only one from the 11th gen pack that isn’t replaced in the 12th gen pack, to work fine with 12th gen boards.

I fixed it! I uninstalled nvidia drivers with DDU and reinstalled them with internet turned off. Computer was crashing during installation, but that was because I was in Windows 11 beta. The installation worked when I reboot into safe mode.