Thunderbolt 3 eGPU not working - Windows 11

Anyone else tried to get a Thunderbolt 3 eGPU working on the FW16?

I’ve got a Lenovo BoostStation, works fine on a couple of other Intel based machines. Tried both rear ports. Laptop detects something is plugged in, and starts charging.

Only device that appears in Device Manager is this :
image

Hi, I have a 3060Ti on a Mantiz Saturn enclosure, it’s working great.

I installed the nvidia drivers with the eGPU connected, and no issue since.
(I did have one blue screen when I first plugged it in, but just that one)

I plug it on the rear-left port.

Tried installing the drivers, both the latest and the older ones off the BoostStation downloads page. Comes back with an error similar to “No Nvidia GPU is detected on your system”.

Could well be something BoostStation specific, as it’s also got onboard Ethernet and a internal drive bay and some USB ports in addition to the GPU, which is in this case an RTX 2060.

It was just plug an play on my old ThinkPad with TB3 running Windows 10, and a newer Intel NUC 11th gen laptop with USB4.

Can you try the left middle? That’s the one I’m using because I was having some issues (not necessarily related to the Framework).

Isn’t that USB3.2 only?

I don’t know if it’s only USB3.2, but the ones supporting Thunderbolt are indeed the two on the rear: Expansion Card Slot functionality on Framework Laptop 16