Touchpad Not Registering Clicks

I feel really dumb now that after a day of tweaking with kernel settings and Wayland and whatnot I read this topic and made the Framework clickpad work just by clicking it hard a lot. Well at least now I have a community account! Super happy with my purchase, just got it hand delivered to the ship where I work, preparing for an expedition to Antarctica. Any other Frameworks down here?

1 Like

After using my Framework Laptop for roughly a month, I’ve found that hard presses work roughly half the time. Soft presses work consistently, but whether it’s the left or right click function, hard pressing the touchpad will be of little to no reliability. Does anyone else have this issue?

*Windows 10
*1TB WD Black
*16GB Ram

My BIOS is up to date, and I haven’t tampered with any software besides disabling DPST Control.

1 Like

Most likely a hardware issue, I’ve also experienced this problem and my replacement input cover is still in shipping to my country. Refer to this thread for more info.

1 Like

I’ve been messing around with this (on Ubuntu) and maybe someone else seeing this problem can verify if they see the same thing.

When the bottom-left corner physical clicks are not working, I pull up the Settings | Mouse & Touchpad | Test your settings… after multiple clicking and double clicking I think I am noticing something.

While I am expecting the click to be in the far left corner; what is working is clicking at about 25% towards the right (ie: half way between the left corner and the middle click).

This worked for me. My symptoms were that the click would register either on its own or with much less pressure than usual, but only when I was using the laptop in a manner where the middle portion was stressed more than the edges - for example, if it were centered on one leg and both hands were on the palm rests. This introduced enough chassis flex to activate the click because the touchpad glass was rubbing on its frame. Moving the touchpad after loosening the screws fixed this issue.

2 Likes

I would also like to say in my experience with fixes the only one that worked for me was pushing the track-pad down really hard not enough to break it lol then it started working no trouble with normal taps and clicks. I’m using windows 10 btw but may help with other distros.

Mine has had intermittent click problems (touch always seems to work).

Today it got really weird. It wasn’t responding to left or right clicks. The settings page didn’t see any clicks registering.

Opened it up to make sure there wasn’t any debris in it.

Now the “left/primary” button only registers in the middle horizontal section of the trackpad (even on the right side). IE above the middle or right button.

@malachid that happened to me as well. A month or two ago I got around to putting in up to an hour to re-align the touchpad. Whatever I did seems to work still, I’m happy with click feel, and I don’t seem to have any missed clicks.

I’ll try to explain what I did and hopefully it helps. It took a lot of fiddling and I did essentially what rjk explained here:

IIRC, I tried to position the touchpad towards the keyboard. And I don’t remember which direction it was, but I remember sliding the touchpad in some direction with some pressure to make sure it stayed in that spot when I screwed it back in. That might of been one of my failed attempts though – it’s been a while so my memory is hazy.

What I do know for sure is that the tolerances are pretty tight. A slight movement in any direction does a lot. So if left click isn’t working, try moving the touchpad to the right. Then the right click might not work. Or the directions might be reversed, etc. Keep adjusting until both clicks feel the same and everything is balanced.

Which leads back to essentially what nrp’s instructions were:


Warning: I don’t recommend the below for reasons explained. Just adding for transparency.

I also messed around with the spring tabs in the bracket. Basically pushing the tabs back inward instead of upward to undo what what I had done incorrectly previously:

I’m not sure if the readjusting the tabs contributed to the fix, or if I was just bringing them back to “normal”. So I can’t safely recommend this, even as a last resort. Contacting support is probably the better option. I was just lazy, wanted to DIY, and eventually got it to work well.


Good luck!

3 Likes

I appreciate the information. I’ll try that out and see if that fixes it for me.

I’ve had my Framework for just about 8 months and ran into the issue of the trackpad not registering clicks. As others suggested, I popped off the keyboard and slightly tightened the two screws that hold the bottom portion of the trackpad in place. Boom, I’m back in business!

2 Likes

I’m having this issue as well and its very irritating. these seems like a very wide spread issue i hope they get this resolved.

So between this thread and another I decided to try to fix it again.

While I had it open, I tried tightening the two screws a little. Couldn’t really tell if they moved or not, if I’m being honest.

I also looked for any debris. There was a cat hair in machine, but not anywhere that should have made a difference. Did my best to clear it of any dust/debris.

While it was still open, I was thinking of the post above about misalignment. Looking at the plate it didn’t seem like it was misaligned. Still, tried moving around in various directions (without loosening first) to see if there was any give or if it was loose. It seemed pretty solid.

I put it back together and went into the Ubuntu > Settings > Mouse & Trackpad settings. There is a button on the top right to test your settings.

Nothing was working. There was another post talking about how they had to press hard in a couple places for it to start working. I pressed hard on the left, middle, right, back and forth a couple times.

It started registering clicks.

For the next week or so, everything seemed to be working fine.

Today, it seemed like it was starting to act up again. I repeated just the Test your Settings portion and got it working again.

So far so good. I definitely find I am less likely to use the laptop if I have to also pull a mouse out as there is not always a hard surface nearby to put it on. Having the trackpad working correctly is imperative to high user retention IMHO.

Just a note about the touch pad. When I realize that it didn’t take the click at all, or properly, it seems to be the range across the pad for the left and right click. That is, if I make very sure I have my finger at the very left or right corner, it registers correctly.

This seems to be the side effect of a one button & area detection by software to determine whether it’s left, right or neutral area. Perhaps the detection areas need tweaks.

Agree with this. For whatever the reason is that the trackpad can’t register my clicks (some times)…it’s been driving me crazy as I can’t use it reliably…and so it’s just not my daily driver. I shouldn’t live with second guessing if this or that computer will take my input when I interact with one.

Similarly…keyboard without fn lock indicator was driving me nuts as well…nor an on-screen indicator. That means the ‘indicator’ now needs to be externalised to my memory. Not the user experience I’ve accustomed to. (When I press F5, I can’t reliably know what it’s trying to do…is it F5, or is it play/pause?)

Damn, you just reminded why I was hesitant on upgrading my mainboard…for reasons beyond the mainboard.

Oh lord, I just figured out why some of my right clicks are not registering correctly…

There seems to be an inconsistent behaviour from the trackpad on how it determines if your click is a left click or a right click…not purely base on where you press down for the physical click on the trackpad…BUT also where your finger first started making that contact.

Test 1:
Initial touch pad state: Nothing touch the touchpad.
Action: Finger press down onto the lower left region for a physical click tactile feedback from the trackpad.
Registered as: Left click. Good

Test 2:
Initial touch pad state: Nothing touch the touchpad.
Action: Finger press down onto the lower right region for a physical click tactile feedback from the trackpad.
Registered as: Right click. Good

Test 3:
Initial touch pad state: Finger touching the lower left region of the touchpad.
Action: Maintain contact between the finger and the touchpad, slide finger across to the lower right region. Now press down for the physical click.
Registered as: Left click. …hum ok…

Test 4:
Initial touch pad state: Finger touching the lower right region of the touchpad.
Action: Maintain contact between the finger and the touchpad, slide finger across to the lower left region. Now press down for the physical click.
Registered as: Left click. …wtf…

The issue is between Test 3 and Test 4.
In test 3, crossing the centre boundary region maintains what the click will be base on the starting contact region.

However, in test 4, crossing the centre boundary region losses what the click will be, ignoring the starting contact region.

Comparison info:
On a ThinkPad W541: The touchpad ignores the starting contact region. Ultimately, where you click down is what that click will be (left/right).
On a ThinkPad P15 Gen 2: I’m getting the same behaviour as the Framework laptop.

1 Like

I wrote up my partial fix for a no physical click condition here:

I just started experiencing this problem. The “just press the bottom/middle really hard” solution seems to have worked, but we’ll see if it lasts…

Hi everyone,

I think Framework (cc. @nrp) should be aware that this issue is not limited to an early batch of laptops and that it still happens with current batches. I received my Framework Laptop 13 today, September 20th 2023. It’s a 13th Gen Intel model (i7-1360p) in a DIY configuration. The sticker on the paper cover of the body indicates a manufacturing date of July 2023.

I did experience this issue after booting into Fedora Linux 39 (Beta):

  • Touchpad movement worked fine,

  • Touchpad gestures worked fine,

  • Touchpad scrolling worked fine,

  • Clicking did NOT work.

  • Right clicking did NOT work.

This thread was the first Google search result for “framework laptop 13 touchpad click not working”. I got my clicking to work. Here’s what I did:

  • Disabling “PS2 Emulation” (as recommended by @Kieran_Levin in this thread) did NOT fix the issue.
  • Clicking by pressing very hard on the touchpad (while taking care not to damage the laptop or anything) about two dozen times fixed the issue permanently.

All I had to do was push down on the touchpad, hard, about two dozen times. Clicks now work without any issue and without undue force.

I have absolutely never been more thrilled to unpack and build a tech product. This laptop is every dream I’ve had about open, truly personal general purpose computing come to life at once and I will be writing more about that in the future, I don’t want to go off topic here. This clicking issue was a bit frightening at first (I was concerned I had damaged the touchpad somehow while assembling the laptop, even though assembly went without issue) but given how easy it was to fix, I don’t consider myself disappointed ultimately.

Going to continue setting up my Framework now – paused to quickly write this up.

1 Like

@nrp: This issue likely wasn’t caught at the assembly line because your mechanical click simulators are clicking at a force much higher than any human would normally click at.

Hey y’all, I’ve finally (seemingly) completely fixed mine!
Note: mine is an 11th gen DIY Batch 1 touchpad that was confirmed to have issues.

I’d been dealing with this for a while (my findings were posted around the beginning of this thread ~August 2021).

Clicking the trackpad “hard” would fix the issue for a while, but it kept coming back. I’d adjusted the metal brackets (I’d actually strongly avoid doing this unless they’re noticeably uneven or you want a different tactile click feel. Bending them into the correct shape within tolerance is not easy. Too much or too little can really ruin the click ability or click feel, and at odd angles can make a squeaky noise when clicked.) I also from time to time realigned the touchpad within the input cover by unscrewing/rescrewing as suggested.

Never got around to sending a ticket for this to Framework because

  1. it wasn’t the biggest issue since I instead mostly used tap to click. Physical click worked most of the time, until it randomly didn’t and needed that “hard” press.
  2. I had already tried bending the brackets as a DIY fix, so I presumed that would nullify the warranty for that part.

Anyway, I got frustrated that the physical click would randomly stop working and took a deeper look. I did this July 21, 2023 and it’s September 24, 2023 now, so it’s been 2 full months of daily use and it’s been working without issue, reliably.

The metal dome switch on the touchpad is adhered by a sticker, which can be peeled off:


Note: it looks slightly misaligned/off-center. I don’t think that was the original state and that was just a pic taken quickly for future reference after messing with it.

I stuck one side of a needle nose tweezer underneath the sticker to gently peel it off. Flipped, you can see the underside of the switch, and where/how the physical click is signaled. When I bridged the contacts with a flathead screwdriver, a click signal was sent reliably.

My memory’s a bit fuzzy and I don’t remember or know exactly what fixed it, but IIRC all I did was:

  • clean the switch and metal contacts with isopropyl alcohol
  • align the switch differently by sticking it e.g. 1mm in a different direction

I may have also done these (these would logically fix the issue provided it fit the cause):

  • bending the dome more inwards
  • I happened to find some spare metal dome switches from another electronic (some old, small USB audio DAC with buttons I kept for parts, picture below). I might have replaced the stock Framework switch with one of those (using the same stock sticker)…but I really don’t remember if I did or not, sorry it was kind of a blur :dotted_line_face: haha

The solution, though, is to get the metal dome switch to reliably close that circuit when pressed down.


In summary, I think just cleaning the contacts and realigning it fixed it. But I may have replaced the entire dome…I don’t remember! Before, the physical click would stop working say a few times a week since Sept 2021. After whatever I did in July 2023, the entire touchpad including physical clicks have been working 100% reliably for at least 2 straight months.

Of course, go through Framework support first, but if this is absolutely your only option, I’d recommend at least trying to clean the switch/contacts since it can easily be adhered back. And then if that doesn’t work, try the other options if you know that the contacts can be reliably bridged. I tested this with a flathead screwdriver on the unscrewed touchpad while my laptop was on and the input cover unscrewed and flipped out (while still connected). Don’t do this unless you want to risk shorting/frying something, but I’m sharing as that was part of my troubleshooting process. YMMV.

Tagging you @nrp with my solution in case this brings any insight.

p.s. I love that things like this can be DIY fixed :slight_smile:

3 Likes